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Program Overview (General Information)

Welcome to askSam for Windows — today's easiest and most advanced tool for managing information. 
Whether you deal with structured information (such as names and addresses) or freeform text (such as E-
Mail and correspondence), askSam can help you put your information where it belongs — at your 
fingertips.

What Is The Purpose Of askSam?
In today's age of electronic information, there are huge amounts of data floating around.    On-Line 
services like CompuServe, Internet, Lexis/Nexis, have mammoth archives of articles. Wire services carry 
streams of press releases. CD-ROMs contain massive encyclopedias of text. The list goes on and on.

Somewhere hidden in the raw data is valuable knowledge — but you must know how to distill the 
important news from the unrefined bulk. That's where askSam can help.

With askSam you spend less time searching for information and more time putting it to use. askSam 
increases the value of information by allowing you to present it in a manner appropriate to your specific 
needs.    

What Is askSam?
askSam is a tool to organize the information that crosses your desk. It doesn't matter whether you deal 
with sticky notes, memos, phone messages, faxes, resumes, depositions, newspaper articles, or e-mail. 
All contain information that you need to track. With askSam we provide a solution.

Simply type, scan, or import your information into askSam. Straight away you can search and retrieve any
word or phrase in the text. Finding your information is easy. askSam offers the widest variety of searches 
found in any database program. These searches include full-text, fuzzy, wildcard, Boolean, proximity, date
and numeric. 

If your information is structured (like names and addresses), you can take advantage of askSam's 
freeform database capabilities. Create an Entry Form for your data.    Every time you add a document to 
your database, call up the Entry Form and fill in the fields. Unlike traditional databases, askSam does not 
require pre-defined field lengths or field types. Fields expand as you enter information, so you never need
to worry about running out of room. 

askSam is as flexible as your information. For example, if you're tracking magazine articles you may want
some fields (like magazine name, date, etc.). You may also want the complete text of the article. 
askSam's unique combination of database and text retrieval features allows you to do just that. You can 
find an article by doing a full-text search and use the fields to create overview reports.    For example, you 
can search for all articles containing "database" and "flexible" and get a sorted list of magazine names, 
article titles, and dates. askSam allows you to add fields to free-form text and turn it a full-text searchable 
database.

Use of the Internet is rising rapidly, and the amount of information on the World Wide Web is dramatically 
increasing. These trends will continue. Tools like askSam will become more important as corporations and
individuals try to sift through and organize the increased flow of information. With askSam you have an 
easy yet powerful way to start managing all of your information.

Once again, welcome to askSam — We hope you will have an enjoyable and productive experience with 
our product.





askSam for Windows Network Version

Using askSam in a Network Environment
In order for multiple users to search, edit, and add to a database, you will require the network version
of askSam. You can contact our Customer Service Department at 800-800-1997 for information on 
upgrading a single user version to a network version of askSam.

Using the network version of askSam is the same as using the single user version except that the 
network version supports record locking, allowing users to work in the same database 
simultaneously.

Opening Files in the askSam Network Version 
In the askSam network version, you can open files either in a Shareable or an Exclusive mode.

Shareable mode allows multiple users to simultaneously search, edit and add information to a 
database. When a user edits a document, that document is automatically locked, preventing other
users from editing that document at the same time. As a default, askSam opens files as 
Shareable.

Exclusive mode limits access to a database to only one user. Other users are denied access 
until the user who opened the database in Exclusive mode closes the database. 

Certain functions require an Exclusive access level:

· Packing a file
· Creating or editing reports
· Editing an Entry Form
· Save As
· Executing a Global Replace
· Defining a Password for a file

If an attempt to perform one of these functions takes place while another user is accessing the 
same file, an error message will occur.

Tip: When working with files that others will not be accessing, use the Exclusive access option. 
When in Exclusive mode, askSam is faster.

Notes
· When creating a new file, it is created in Exclusive mode. The file must be closed before 

other users can enter the file.
·
· A File Edit password can be defined to protect a file. This would only allow users with 

the password to edit the file. Other users would only be able to access the file in a read-
only mode.

·
· You can modify askSam to have the OPEN dialog default to an Exclusive option instead 

of Shareable when opening askSam files. To set this option, open an askSam file and 
see the OPTIONS -> GLOBAL PREFERENCES menu. Change the Default File Setting 
to Exclusive.

Exiting askSam (Important)
It is important to properly exit askSam by choosing FILE -> CLOSE. If    a document is locked and the



computer is turned off    without first exiting askSam, that document will remain locked the next time 
you access the file. To remove any incorrectly locked documents, choose FILE -> PACK to pack the 
file. 



New command (File menu)

Use this command to create a new file in askSam.    You can open an existing file with the Open 
command.

Shortcut
Toolbar:  
 Key Stroke: Ctrl+N

Dialog Box Options

File Name:
Enter a name for the new file.

Use Template:
Select a template to structure your new file. Select NONE to create an empty file.

NOTE: askSam comes with standard templates for a variety of tasks:    contact management, writing 
faxes, clippings, a calendar file. New templates will continually be added and existing ones updated. The 
README file contains an up-to-date list of the templates and a brief description of each.

Directories and Drives
Select the Drive and Directory for the new file if it is not the current directory.

________________
See also

Close command (File menu)
Open command (File menu)
Save command (File menu)
Save As command (File menu)



Open command (File menu)

Use this command to open an existing file in askSam.    You can create a new file with the New command.

Shortcut
Toolbar:  
Key Stroke: Ctrl+O

Dialog Box Options

File Name
Type or select the name of the file you want to open.

List Files of Type
Select the format of the file you want to open.    Click the down arrow to view the available file formats.

Directories
Select the directory from which you want to open the file.

Drives
Select the drive from which you want to open the file.

Read Only
Click the box to open the file in Read Only Mode.    Files opened as Read Only cannot be edited.

The following options appear only in the Network Version:

Exclusive
Click the button to open the file in an Exclusive Mode. Files are opened to allow access to only one user. 
Other users are denied access until the file is closed.

Shareable
Click the button to open the file in a Shareable Mode. Files are opened to allow multiple users to 
simultaneously search, edit and add information. 

_______________
See also

Close command (File menu)
New command (File menu)
Save command (File menu)
Save As command (File menu)
Network Version 



Save As command (File menu)

Use this command to save the current file with a new name or in a new location.    

Note:    To save a file with its existing name, and location, use the Save Command.

Shortcut
Toolbar:  

Dialog Box Options

File Name
Type or select the name of the file you want to save.

List of File Type
Select the extension for the file you are saving. This does not affect the format in which your file is saved. 
To save your data in another format, see the Export command.

Directories
Select the directory where you want to store the file.

Drives
Select the drive where you want to store the file.

_______________
See also

Close command (File menu)
New command (File menu)
Open command (File menu)
Save command (File menu)
Export command (File menu)



Save command (File menu)

Use this command to save any changes you've made to the current file. 

Note:    To save an existing file under another name, use the Save As command.

Shortcut
Toolbar:  
Key Stroke: Ctrl+S

Dialog Box Options

File Name
Type or select the name of the file you want to save.

List of File Type
Select the extension for the file you are saving. This does not affect the format in which your file is saved. 
To save your data in another format, see the Export command.

Directories
Select the directory where you want to store the file.

Drives
Select the drive where you want to store the file.

_______________
See also

Close command (File menu)
New command (File menu)
Open command (File menu)
Save As command (File menu)
Export command (File menu)



OCR (File Menu)

The ReadIris OCR Module is a powerful intelligent Optical Character Recognition (IOCR) system which 
lets you scan documents directly into an askSam database.

To scan resumes, papers, articles, or other documents into askSam make sure you are in the document 
where you want to scan the information. Choose File -> OCR.

NOTE: The ReadIris OCR Module is an add-on product which you can purchase separately from 
askSam. For details, contact askSam Systems at 800-800-1997 or 904-584-6590.

Dialog Options

Scanner/File Determines if you are scanning from your scanner or from a TIFF file.

Unformatted/Formatted Unformatted scans in texts without any formatting information. Formatted 
scans in text with paragraph and indentation formats.

Auto Page Analysis When Auto Page Analysis is checked, the text and graphics blocks are 
automatically detected and sorted. If this option is not checked, you can 
manually select the areas you wish to OCR and the order in which they are
scanned.

# of Pages to Scan If you plan to scan more than a single page into an askSam document, 
enter the number of pages you will scan in this field.

Learn Mode When checked, ReadIris displays any doubtful characters for your 
approval. This feature lets you teach ReadIris to recognize unusual or 
poorly printed characters.

Keep OCR Loaded After you finish scanning a document with the ReadIris OCR Module, 
askSam automatically removes ReadIris from memory. If you plan to scan 
many documents, you can check this option, and ReadIris will remain 
loaded after the text is scanned. This will save time when you scan the 
next document.

Change OCR Dictionary If you run ReadIris on many documents of the same type, you can define 
specific font dictionaries for these documents. You can store learned 
characters in these dictionaries. This will save you time when you scan 
similar documents. The Append/New options let you choose whether you 
will create a new dictionary or append entries to an existing dictionary. As 
a default setting, the ASKSAM.DUS is loaded as your dictionary.

1. Choose the appropriate options and choose OK to begin scanning your document. The ReadIris OCR 
Module is loaded. Follow the instructions in the ReadIris User's Guide for scanning information.

2. When you've completed scanning and recognizing the information, you return to askSam, and the 
information is automatically inserted in your Document.



Page Setup command (File menu)

Use this command to change margins, paper source, paper size, and the direction the text appears on the
page for any section of your document or file.

Dialog Box Options

Options 
Select the range for the Page Setup command.

File Settings Sets the default page setup settings for the current file.

Document Settings Sets the default page setup settings for the current document.

Margins
Displays the Margins options.
Top Specifies the distance between the top of the page and the top of the first line of the page.

Bottom Specifies the distance between the bottom of the page and the bottom of the last line on the 
page.

Left Specifies the distance between the left edge of the page and the left end of each line.

Right Specifies the distance between the right edge of the page and the right end of each line.

Orientation
Lets you choose whether you print in portrait or landscape mode.

Header
Use this option to insert text at the top of every page in a document or file. 

Footer
Use this option to insert text at the bottom of every page in a document or file.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    The default printer for askSam is the 
printer defined in the Windows Control Panel.

Dialog Box Options

Printer Selects the printer you want to use; only installed printers appear.    You install 
printers and configure ports through the Windows Control Panel.

Default Printer Selects the default printer as defined in the Windows Control Panel.

Specific Printer Selects a printer and printer connection other than the default printer.    All installed 
printers will appear in the Specific Printer list.

Orientation
Select the direction you want the text to appear on the page - either portrait or landscape.

Paper
Select the paper size.

Options
Select the dithering, intensity control and print quality for your print job.

_______________
See also

Print command (File menu)



Print command (File menu)

Use this command to print the current document, entire file, selected text, selected document(s), report, 
or pages of a document.

Shortcut

Toolbar:  
Key: Ctrl+P

Dialog Box Options

Current Document Prints the current document.    The default setting.

All Documents Prints all documents in the current file.

Selection Prints the selected (highlighted) text in the current document.

Selected Documents Prints documents selected using the Multiple Search Dialog Box.

Report Prints the output of a Report created with the askSam Report Writer.    The 
Run Report Dialog Box will appear. 

Pages Prints a range of pages of the current document.    After selecting this option,
type the page numbers in the FROM and TO boxes.

Print Quality
Changes the quality of the graphic images.    

Note:    This option is printer dependent and is not available for all printers.

Print to File
Saves the document or documents you print as a printer file.

Print each Document on a Separate Page
With this option checked, askSam inserts a Form Feed (page break) between documents whenever you 
print multiple documents. If this option is not selected, the Output Separator for your file is inserted 
between documents.

Copies
Use this option to prints multiple copies of the print job.    The default setting is 1.

Setup
Use this option to select a printer and a printer connection.    See the Print Setup command for more 
information on the Print Setup Dialog Box.

_______________
See also

Print Setup command (File menu)



Import command (File menu)

Use this command to import information into askSam. You can import information from various formats: 
texts, word processing documents, databases, E-Mail, and the Internet. See below for a complete list of 
the formats you can import into askSam.

Shortcut

Toolbar:  

Dialog Box Options

File Name
Type or select the name of the file you want to import. You can select multiple files by clicking on each of 
the file names.

File Type
Select the format of the file you want to import.    Click the down arrow to view the available file formats:

 Text Only ASCII text files. Imported without word wrap or tabs

Text Formatted ASCII text files. Imported with word wrap and tabs.

askSam DOS Format for exchanging data between the DOS and    Windows versions of 
askSam. Also useful for transferring information between askSam for 
Windows files. This format retains Document Boundaries between askSam 
Documents. 

CompuServe Messages from the CompuServe Information Manager - *.ART, *.MSG, 
*.NWS, *.PLX, *.THD.

Comma Separated Data separated by commas. Use this format to import data from      
spreadsheets and other databases.

dBASE  dBASE III, III+ and IV, FoxPro, Clipper and other DBF files. The dBASE 
filter also imports memo fields from your databases.

Eudora E-Mail messages from Eudora mailbox files.

Fixed Position Data stored in fixed column positions. Use this format to import data from 
spreadsheets and other databases.

HTML Files HTML (Hypertext Markup Language) files from the World Wide Web 
(Internet). The HTML import support the import of graphics. 

Lexis/Nexis Files from Mead Data's On-Line systems Nexis (news articles) and Lexis 
(legal rulings)

RTF Files Rich Text Format files used to exchange formatted information 
(including .BMP Graphics.)

Tab Delimited Data separated by tabs. Use this format to import data from spreadsheets 
and other databases.

Word for Windows 6.X Microsoft Word for Windows 6 files with formatting.

WordPerfect 5.X WordPerfect version 5 files with formatting.



WordPerfect 6.X WordPerfect version 6 files with formatting.

Directories
Select the directory from which you want to import the file.

Drives
Select the drive from which you want to import the file.

Select all
Click on this option to import all the files of the specified type and in the specified location.

Automatic Field Recognition
Auto Field Recognition recognizes fields in imported information. Field Recognition takes place 
immediately after your import is complete. You can also access Auto Field Recognition by choosing 
TOOLS -> AUTO FIELD RECOGNITION.

Import into Entry Form
With this option checked, your documents are imported into the Entry Form. If you are importing text or 
word processing documents, the text or documents are appended to the end of the Entry Form. If you are 
importing data (dBASE, CSV, Tab, or Fixed Position), you can import the data directly into fields in your 
Entry Form.

Windows ANSI Format
Windows and DOS use different character sets for extended characters. If you import texts written in 
another language, you may notice that certain accented characters do not appear correctly in Windows. 
The ANSI setting in the Import menu lets you transfer information without encountering this problem. 
When importing DOS texts into askSam, the ANSI option should not be checked. When importing texts 
from another Windows application, the ANSI option should be selected.

Import Options
Choose the Set Options button to access the Import Options dialog box. The Import Options dialog box 
lets you define the Document Delimiter and the Append Location.

Append Location
Defines the location where imported text is added to askSam file. Choose from the following options:

End of File Adds the imported text to the end of the current file (default setting).

End of Current Document Adds the imported text to the end of the current document.

After Current Document Adds the imported text in a new document inserted located directly after
the current document in the current file.

After Tagged Document Adds the imported text in a new document located directly after the 
tagged document in the current file.

Document Delimiter
When you import a text into askSam, the Document Delimiter defines how to separate the text into 
documents in your askSam database:

No Delimiter (Default setting) The entire file you import is stored in askSam as a single document. If 
you import multiple files, each of these is stored as a separate askSam document in 
your database.

Blank Line Each time askSam encounters a blank line in the imported text, a new askSam 



document is created for the next block of imported text.

Page Break Divides the file you import into askSam Documents wherever hard page breaks are 
encountered. Hard page breaks are page breaks set using the word processors page 
break command. In .TXT files the ASCII 12 character is understood as a Page Break.

Lines Lets you specify a number of lines as a delimiter. askSam creates a new Document 
each time the specified number of lines is imported.

String Allows you to enter a string of characters which askSam will use to separate imported 
information into multiple Documents. The character string can contain 256 characters. 
Pressing ENTER inserts a CR/LF (carriage return / line feed) into the string. The 
Remove Delimiter String option lets you remove the Delimiter String from the imported 
information.

Date Button
The Date button imports CompuServe messages before or after a specified date. This option is only 
available when importing CompuServe Information Manager files.

_______________
See also

Importing Information (Step-by-step Instructions)
Export command (File menu)



Export command (File menu)

Use this command to export information from your askSam file into another format and file. You can 
export the current document, entire file, tagged document, selected document(s), selected text, or a 
report. You can export from askSam into a text file, word processing format, HTML format, Comma 
Delimited format, and more.

Export sub-Menu Options

Current Document Exports the document displayed on the screen.

Entire File Exports all documents in the current file.

Tagged Document Exports the Tagged Document (only available if a Document is tagged in the 
current file.)

Selected Documents Allows you to Export a Selected group of Documents.    This option accesses 
the Multiple Search Dialog Box. Enter a Selection and only the selected 
Documents are exported.

Selection Exports the selected (or highlighted) text in the current Document.

Report Exports the output of a Report. Selecting this Option will display the RUN 
REPORT Dialog Box. Select the Report you wish to Export and choose OK.

Dialog Box Options

File Name
Type or select the name of the file into which you want the information exported.

File Type
Select the format of the document you want to export.    Click the down arrow to view the available file 
formats:

Text Files ASCII text file.

askSam DOS Format for exchanging data between the DOS and Windows versions 
of askSam. It is also useful for transferring information between 
askSam for Windows files. This format retains the Document 
boundaries between askSam Documents.

askSam for Windows Creates a new .ASK file from exported information.

Comma Separated Values Comma separated values can be used to Export data for Mail Merge 
with a word processor or for use with most database programs.

HTML Files Creates an HTML (Hypertext Markup Language) document. HTML is 
the standard format used on the World Wide Web (Internet).

RTF Files RTF files can be used to exchange formatted information 
(including .BMP Graphics.)

Tab Delimited Data separated by tabs. Use this format to export data for Mail Merge 
with a word processor or for use with most database programs.

Word for Windows 6.X Microsoft Word for Windows version 6 with formatting.

WordPerfect 6.X WordPerfect version 6 with formatting.



Directories
Select the directory where you want to export the document.

Drives
Select the drive where you want to export the document.

Append File
Adds the exported information onto the end of the file. This option is not available in all file type.

Export Options
Choose the Set Options button to access the Export Options dialog box. From the Export Options dialog 
box you can define the Document Delimiter. 

Document Delimiter
The Document Delimiter defines a delimiter which will be output between Documents when you Export 
multiple Documents. Choose from the following delimiters:
 

No Delimiter Exports the file without inserting a delimiter between Documents. This is the Default 
Setting.

Blank Line Inserts a Blank Line after each Document that is Exported.

Page Break Outputs a Page Break after each Exported Document. If you are exporting to TXT an 
ASCII 12 character is used as the page break character.

String Allows you to define a character string to output as a delimiter between Documents.

ANSI Format
Determines if data is exported in ANSI or OEM format. In general, if you are exporting to a Windows 
application, select the ANSI option. If you are exporting to a DOS application, the ANSI option should not 
be checked. This setting is only necessary if your texts contain extended characters (such as accent 
characters in other languages). 

_______________
See also

Exporting Information (Step-by-step Instructions)
Import command (File menu)



Index Command (File menu)

Note: Indexing is only available in the askSam Professional version.

Full-Text Indexing greatly speeds up searching in askSam files, especially in large files. With full-text 
indexing, you can search through a several hundred MB askSam file in a matter of seconds. 

When you index an askSam file, askSam creates a list of all the words in the file and records the 
document where these words were found. When you search, askSam can quickly search the list of words 
(the index) and jump to the appropriate document in your file. 

The search procedures are the same for indexed and non-indexed files. If you choose to index an 
askSam file, askSam will automatically use the index when searching the file. This will dramatically 
increase the speed of your searches. 

Using the Index Command

To index a file:

1. Choose FILE -> INDEX.
The INDEX Dialog Box will appear. A Meter Bar on your screen will display the progress. After 
indexing, askSam returns to the first Document in the file.

NOTES: 
1. The time required to index a file is a one time investment. Once an index is created, askSam will 

maintain the index as you edit, delete, and add information to your file.
2. After a file is indexed, you will see a check mark next to the Index command in the File menu. This 

check mark indicates that the file is indexed. Choose the Index command a second time to delete 
the index.

3. The speed of indexing is highly dependent upon your hardware/software configuration. On a fast 
machine with the proper configuration, you can index about 1 MB per minute.

4. The size of the index relative to your file size will depend upon the information in your file. 5.
Generally, the index size is about 30% of the file size. In small files this percentage will be higher. 

5. When you index an askSam database, two index files are created - an *.IDX file and a *.DTA file. 
These files contain the index information. If you delete or move these files, you will need to re-index 
your file.

6. There are several options that affect the size, speed, and contents of your index. The Index Options 
can be set in the OPTIONS -> FILE PREFERENCES menu. See Index Options. 

_______________

See also
Index Options



Pack command (File menu)

Use this command to permanently remove deleted documents and reclaim fragmented space.    Packing 
should be done periodically to decrease file size and speed searches.

Note: If askSam encounters a file that is fragmented, it will automatically prompt you to pack the file.



Undelete command (Edit menu)

Use this command to restore deleted text to its original position in the current document.

Shortcut

Key: Ctrl+Z



Cut command (Edit menu)

Use this command to remove a selected text or a selected graphic from a document and put it in the 
Clipboard.    This command is not available if you have not selected a text or graphic.

NOTE:    Cutting text or graphics to the Clipboard replaces the contents previously stored in the 
Clipboard.

Shortcut:
Keys: Ctrl+X

Toolbar:  
_______________
See also

Copy command (Edit menu) 
Paste command (Edit menu) 



Copy command (Edit menu)

Use this command to copy a selected text or graphic to the Clipboard.    This command is unavailable if 
you have no selected text or graphics.

NOTE: Copying to the Clipboard replaces the contents previously stored there.

Shortcut:
Toolbar:  
Keys: Ctrl+C

_______________
See also

Cut command (File menu) 
Paste command (File menu) 



Paste command (Edit menu)

Use this command to insert a copy of the Clipboard contents at the cursor position. This command is not 
available if the Clipboard is empty.

Shortcut

Toolbar:  
Keys: Ctrl+V

_______________
See also

Cut command (Edit menu) 
Copy command (Edit menu) 



Delete command (Edit menu)

Use this command to remove a selected text or graphic from a document.    

NOTE:    To restore the deleted text to its original location, use the Undelete command.

Shortcut

Keys: Del

_______________
See also

Selecting Text (Using the askSam Word Processor)



Paste Special command (Edit menu)

Use this command to paste an existing object or graphic into the current document without having it linked
to a source file in a Server Application. 

NOTE:    To enable updating the object, use the Paste Link command.

Dialog Box Options

Data Type
Select the type of information you are pasting.

Paste
Inserts the object or graphic without creating a link to the source file in the server application.

Paste Link
Inserts a link to the server application and its data into the document.

________________
See also

Paste Link command (Edit menu)
Insert Picture command (Edit menu)



Paste Link command (Edit menu)

Use this command to insert an OLE Link    to information in another application.

_________________
See also

Paste Special command (Edit menu)



Select All Command (Edit menu)

Use this command to select the entire document displayed on your screen. This is useful is you want to 
copy the contents of the entire document, or if you wish to change a format (such as font or margin) for 
the entire document.



Find command (Edit menu)

Use this command to search for a word or phrase in the current document.

Shortcut
Keys: Shift+F3

Dialog Box Options

Find What
Type or select the word or phrase you want to search for.

Match Case
Click on the box to define the Find search as case sensitive.

Find Next
Click on the Find Next Button to search for the next occurrence of the word or phrase in the current 
document.

Cancel
Click on the Cancel Button to stop the Find search at the current position in the document. 
 
Note:    To reexecute the last Find search request, press F3.

_______________
See also

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Repeat Last Find 



Repeat Last Find command (Edit menu)

Executes the last Find command.    See the Find command (Edit menu)

Shortcut
Keys: F3

________________
See also

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Replace command (Edit menu)

Use this command to replace a text string in the current document with another text string.

Dialog Box Options

Find What
Type or select the word or phrase you want to replace.

Replace With
Type or select the word or phrase you want inserted in the document.

Match Case
Click the Box to define the Replace search as case sensitive.

Find Next
Click the Find Next Button to find the next occurrence of the word or phrase you want to replace.

Replace
Click the Replace Button to replace a single occurrence of the text in the document.

Replace All
Click the Replace All Button to replace every occurrence in the document.

_______________
See also

Global Replace command (Edit menu)



Global Replace command (Edit menu)

Use this command to change specified text string to another text string in the every document in the 
current file.

IMPORTANT: A Global Replace cannot be undone. We recommend always making a Backup before
using the Global Replace Command.

Dialog Box Options

Find What
Type or select the text you want to replace in the file.

Replace With
Type or select the text you want inserted in file.

Match Case
Click the Box to define the Global Replace search as case sensitive.

All occurrences per document
Click the Box if you want to replace all occurrences of the text in each document in the current file.    
askSam's default setting is to replace only the first occurrence of the text in each document in the file.

Replace
Click the Replace Button to replace a single occurrence of the text in the file.

Replace All
Click the Replace All Button to replace every occurrence in the file.

Only in Selected Documents
The Multiple Search Dialog will appear, and you can define a Search Request. The Global Replace will 
only be executed in the Documents selected by the Search Request.

NOTES:
1. To keep your file compact, and to speed your searches, it is important to Pack your file after you 

execute a Global Replace. 

2. The Global Replace Command can be used to modify your Field Names. Type the current Field 
Name in "Find What" and type the name you want in "Replace with".

3. Wildcards are allowed in the Global Replace Command. 

_______________
See also

Replace command (Edit menu)
Multiple Search Dialog 



Stamp command (Edit menu)

Use this command to insert the time, date, and weekday in the current document.
To modify the time and date formats, use the Date/Time Formats command (Options menu).

Shortcuts

Toolbar:

Time  

Date  
Keys:

Date Ctrl+D
Time Ctrl+T

Stamp sub-Menu Options

Date
Inserts the system date in the current document at the cursor position.

Time
Inserts the system time in the current document at the cursor position.

Weekday
Inserts the system weekday in the current document at the cursor position.



Insert Object command (Edit menu)

Use this command to insert a new object in the current document.    To insert an existing object in the 
current document, use the Paste or Paste Special commands.

Dialog Box Options

Object Type
Type or select the type of object you want to insert.    The appropriate server application will open to allow 
you to create the object.

_______________
See also

Links command (Edit menu)
Object command (Edit menu)



Insert Picture Command (Edit menu)

Use this command to import graphics from various formats into askSam documents.

Using the Insert Picture Command

To Insert a Graphic:
1. Place the cursor where you want to insert the graphic.
2. Choose EDIT -> INSERT PICTURE. 

The Insert Picture dialog box will appear. 
3. Select the graphic file you want to insert and choose OK.

The graphic is inserted in your document.
 

Dialog Box Options

File Name
Enter or select the name of the graphic.

List File of Type
Select the format of the graphic you want to insert.    Click the down arrow to view the supported graphic    
formats.

Directories
Select the directory where your graphic is located.

Drives
Select the drive where your graphic is located.
_______________
See also

Picture Attributes (Edit menu)



Picture Attributes

Use the Picture Attributes commands to modify a graphic inserted with the Insert Picture command.

Using the Picture Attributes

To Edit a Graphic:
1. Click on the graphic you wish to edit.

The graphic will be selected. Handles appear around the graphic.

2. Choose EDIT -> PICTURE ATTRIBUTES.
A menu will appear with the following commands:

Flip Horizontal - flips the selected graphic horizontally.
Flip Vertical - flips the selected graphic vertically.
Rotate - rotates the selected graphic 90, 180, or 270 degrees.
Invert - inverts the colors in the graphic (normally used with black and white images).
Adjust - adjusts the brightness, contrast, and sharpness of the graphic.

NOTES:
1. The PICTURE ATTRIBUTES will not work on OLE objects.

2. Graphic Compression - To conserve space, askSam automatically stores all graphics in a 
compressed format. 

_______________
See also

Insert Picture Command (Edit menu)



Flip Vertical (Edit menu)

Flips a selected graphic vertically.
_______________
See also

Picture Attributes (Edit menu)



Rotate 90° (Edit menu)

Rotates a selected graphic 90 degrees.
_______________
See also

Picture Attributes (Edit menu)



Rotate 180° (Edit menu)

Rotates a selected graphic 180 degrees.
_______________
See also

Picture Attributes (Edit menu)



Rotate 270° (Edit menu) 

Rotates a selected graphic 270 degrees.
_______________
See also

Picture Attributes (Edit menu)



Invert (Edit menu)

Inverts the colors in a selected graphic (normally used with black and white images).
_______________
See also

Picture Attributes (Edit menu)



Adjust (Edit menu)

Adjusts the brightness, contrast, and sharpness of a selected graphic.

Use the slide controls to adjust the settings. The Reset button returns all settings to their original values.

_______________
See also

Picture Attributes (Edit menu)



Entry Form command (Edit menu)

Use this command to turn the Entry Form Editor ON.    This enables you to create an entry form for your 
file, or to edit an existing entry form.    To turn the Entry Form Editor OFF and save the Entry Form, 
choose the Entry Form command again.

Data Entry Mode
When you turn the Entry Form Editor you are prompted to save changes. In the save changes box is an 
option to Turn On Data Entry Mode. If marked the current askSam file will default to data entry mode. If 
the data entry box is not marked the file will default to a word processing mode.

______________
See also

Add w/Entry Form command (Document menu)
Creating an Entry Form (Step-by-Step Instruction)



Display (View Menu)

Allows you to increase your Work Space by selectively hiding various sections of the screen.

Changing The askSam Screen
From the View Menu, you can choose to remove any of the following:

· Tool Bar
· Format Bar
· Command Line
· Status Bar
· Ruler

To hide (or restore) the various sections of the askSam screen:

The dialog lists the removable sections of the askSam screen. Select the screen sections you want to 
change and choose OK. The askSam screen changes to reflect your selection.

NOTE: askSam defaults to having all screen sections ON.



Hypertext Link (View menu)

If selected, this option will execute a hypertext link.

Shortcut
Keys: CTRL-ENTER

Move the cursor onto the Linked word or phrase (the green underlined text). Press CTRL+ENTER (or 
choose VIEW -> HYPERTEXT LINK)

One of five things will happen depending on the type of link you defined:

1. You will jump to another location.
2. A Report will be run.
3. An askSam Menu Command will be executed.
4. You will run an external application.
5. A Hypertext URL will be displayed.

______________________
See also

History command (View menu)
Backtrack command (View menu)
Set Hypertext Link (Document menu)



History (View menu)

When you navigate through files with Hypertext, there are times when you will want to return to a previous
Hypertext Link. The History command displays a list of the Hypertext Links you've viewed. You can select 
any Link and return to it.

To Display a List of the Previous Hypertext Links (History):

1. Choose VIEW -> HISTORY
The Hypertext History Dialog Box will appear. This dialog contains a list of the Hypertext Links you've
used during this session with askSam.

2. Select the name of a Hypertext Link and choose OK.
You will return to the Hypertext Link you selected.

_______________
 See also

Hypertext link command (View menu)
Backtrack command (View Menu)



Backtrack (View menu)

If selected, you return to the previous Hypertext Link.

_______________
See also

Hypertext link command (View menu)
History command (View Menu)



Bookmark (View menu) 

Use this command to view a bookmark.

Shortcut
Keys: Ctrl + F2

This dialog contains a list of all the Bookmarks in the active file. Select the name of the Bookmark you 
wish to view and choose the OK button. You jump to the line containing the selected Bookmark.

_________________
See also

Set Bookmark command (Document menu)



Next command (View menu)

Use this command to move to the next document in the current file.

Shortcut
Toolbar:  

Keys: Alt + PgDn

_________________
See also

Previous command (View menu)
First command (View menu)
Last command (View menu)



Previous command (View menu)

Use this command to move to the previous document in the current file.

Shortcut
Toolbar:  

Keys: Alt + PgUp

__________________
See also

Next command (View menu)
First command (View menu)
Last command (View menu)



First command (View menu)

Use this command to move to the first document in the current file.

Shortcut
Toolbar:  

Keys: Alt + Home

________________
See also

Next command (View menu)
Previous command (View menu)
Last command (View menu)



Last command (View menu)

Use this command to move to the last document in the current file.

Shortcut
Toolbar:  

Keys: Alt + End

_______________
See also

Next command (View menu)
Previous command (View menu)
First command (View menu)



Go to Document # command (View menu)

Use this command to access a document by entering its document number.    The document number 
appears at the bottom of the screen in the Status Bar (Doc # of #). 

For example, entering 1 will take you to the first document in a file.



Go to Tagged command (View menu)

Use this command to move to the tagged document in the file.

Shortcuts
Toolbar:  

Note: To tag a document, use the Tag command (Documents menu).

_______________
See also

Tag command (Document menu)



Update Document Counter Command (View menu)

When you use Hypertext, bookmarks, or index searches to access a document, the Document Counter is 
turned off. Choosing VIEW -> UPDATE DOCUMENT COUNTER will turn the Document Counter back on.

The Document Counter is displayed in the Status Bar.



Zoom Out (Tool Bar)

Zoom Out reduces the size of the Document on your screen.

  
____________
See Also 

Zoom In (Tool Bar)
Zoom Command (View Menu)



Zoom In (Tool Bar)

Zoom In enlarges the Document on your screen.

  

____________
See Also 

Zoom Out (Tool Bar)
Zoom Command (View Menu)



Zoom command (View menu)

Use this command to enlarge or reduce the current document on the screen.

Shortcuts
Toolbar:

Zoom In  

Zoom Out  

Dialog Box Options

Magnifications
Select the magnification you want for the document.

200% Magnifies the document 200 percent of its original size.
100% Returns the document to its original size. This is the default setting.
75% Reduces the document to 75 percent of its original size.
50% Reduces the document to 50 percent of its original size.
25% Reduces the document to 25 percent of its original size.
Custom Use this option to designate a specific magnification for the document. Type the 

magnification level you want in the Box.



Search Multiple Files (Actions Menu)

Allows you to search a group of askSam files.

Dialog Options

Files to Search
Displays a list of the files to be searched.

Search
Allows you to build a search using the Multiple Search Request Dialog Box

Add Files
Lets you select files to search

Remove
Removes a file from the list of files to search

Remove All
Removes all files from the list of files to search

___________________
See Also

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Multiple Search Request 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Boolean Search command (Actions menu)

Use the Boolean Search command to search using the Boolean operators AND, OR, and NOT.

EXAMPLE: You could conduct a Boolean Search in a file containing business letters to find all 
those sent to Illinois but NOT to Chicago. 

    Using the Boolean Search Command

1. Enter the a word or phrase that you wish to locate.
NOTE: If you are only looking for this word or phrase choose OK and askSam will begin Searching.

2. Choose ADD.
The word or phrase will be added to the Search List.

3. Choose a Boolean operator - either the AND, OR, or NOT Button.
If no Boolean operator is selected, an AND is understood and the word or phrase will be required in 
your Search. 

4. Continue steps 1, 2, and 3 until your search request is complete
5. Choose OK to start the search.

Dialog Box Options

Word or Phrase
Type or select the word or phrase you want to search for in the current file.

Boolean Operators
Select the Boolean operator you want to use to connect the words or phrases in your search request.
Note:    If no Boolean operator is selected, an implied And is used to connect the search request.

AND Selects Documents which meet two or more search criteria. For example a search to find 
resorts with:

Golf AND Tennis AND Beach*

OR Defines multiple criteria for selecting Documents. For example a search to find resorts in:
Florida OR Hawaii OR California

NOT Selects Documents which do not meet the criteria immediately following the Boolean Operator 
NOT. For example find resorts that are:

NOT expensive AND NOT crowded

Fuzzy Search Button
Searches for a fuzzy equivalent of the word you enter. For example, a Fuzzy Search for "Kathy" would 
find "Kathy", "Kathi", "Cathy", and "Katey".

Search List
Displays the search request as you construct it. The following buttons affect the search list:

Add Adds the Word or Phrase to the Search List.

Replace Replaces the selected Word or Phrase in the Search List.



Clear Removes the word, phrase, or Boolean operator that you select in the Search List.

Clear All Removes all word, phrases, and boolean operators in the search list

Move Up Moves a word or phrase and its boolean operator up one line in the Search List

Move Dn Moves a word or phrase and its boolean operator down one line in the Search List

Word List Button (only in askSam Professional)
In an indexed file, the Word List button will appear. Choose this button to display a list of the words 
contained in the file.

Max Hits (only in askSam Professional)
In an indexed file, the Max Hits field displays the number of documents that will be retrieved by your 
request.

Priority in Boolean Searches

In both the Boolean Search Dialog and the Multiple Search Request Dialog the your searches are 
inserted in a Search List. The first item you define is first in the list, and the rest are added to the end of 
the list. 

The entries in a Search List are executed from top to bottom. This means that the first item in your search
list is the first to be searched for when askSam executes the search.

Complex searches (searches containing AND and OR operators) at times require a way to denote priority.
In askSam you define how items in a search are grouped and prioritized by including or not including the 
Boolean operator AND. Entries in your search list that do not contain an AND and are not followed in the 
next line by an OR or AND are always required. For example:

Software
DOS

OR Windows
Application

Documents retrieved by this request:
· Must contain the word "Software"
· Contain either "DOS" or "Windows"
· Must contain the word "Application"

Now a similar request with a Boolean AND. Notice the difference:

Software
AND DOS
OR Windows
AND Application

Documents retrieved by this request:
· Must contain either the words "Software" and "DOS"
· or the words "Windows" and "Application"

________________
See also

Search in Field 
Numeric Search 
Proximity Search 



Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Search in Field command (Actions menu)

The Search in Field Command allows you to search for a word or phrase in a specific Field.
For example: to find a Document containing "White" in the Name Field, use the Search In Field 
Command. Simply doing a search for "White" from the Command Line or the Boolean Search Dialog Box 
would find "White" anywhere in the Document, not just in the Name Field.
              
Using the Search in Field Command

1. Enter a word or phrase.
2. Enter the name of the Field in which you wish to search.
3. Choose OK.

askSam will retrieve all Documents containing the word or phrase in the Field you specified.

Dialog Box Options

Word or Phrase
Type or select the word or phrase you want to find in the current file.

in Field
Type or select the field in which you want to search for the word or phrase.

Fuzzy
Click on this option to search for a fuzzy equivalent of the word you enter. For example, a Fuzzy Search 
for "Kathy" would find "Kathy", "Kathi", "Cathy", and "Katey".

Empty 
Searches for Documents where a field is empty.

Not Empty 
Searches for Documents where a field is not empty.

Multi-line Field
Click on this option if the field you are searching contains more than one line.

Note:    The default setting is that the field is a single line.    The end of a multi-line field is a closing bracket
( ] ) or the end of the document.

Word List Button (only in askSam Professional)
In an indexed file, the Word List button will appear. Choose this button to display a list of the words 
contained in the file.

Max Hits (only in askSam Professional)
In an indexed file, the Max Hits field displays the number of documents that will be retrieved by your 
request.

_______________
See also

Boolean Search 
Numeric Search 



Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Numeric Search command (Actions menu)

Use this command to search for documents based on a numeric comparison of fielded information.

EXAMPLE: You could conduct a Numeric Search to find all documents where the amount field 
was greater than $10,000.

Using the Numeric Search Command

1. Enter the name of a Field containing a Numeric Value.
2. Choose the Numeric Operator (<, >, =, <=, >=, <>).
3. Enter a number.
4. Choose OK.

askSam will retrieve all Documents containing a value in the specified Field which meets your 
numeric criteria.

Dialog Box Options

Field
Type or select the field in which you want to search.    It must be a field containing a numeric value.

Numeric Operator
Type or select the numeric operator that you want to use in your search request.

Numeric Value
Type the numeric value you want to use in your search request.

_______________
See also

Boolean Search 
Search in Field 
Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Proximity Search command (Actions menu)

A Proximity Search allows you to search for two words or phrases occurring within a specified proximity of
one another.    

EXAMPLES: You can find all Documents where "Thatcher" and "Reagan" appear in the same 
paragraph. Or you could locate the Documents containing "GM" and "Ford" within 5 words of one 
another.

Using the Proximity Command

1. Enter the first word or phrase.
2. Enter a number in the quantity field - or leave it blank if the words are to appear in the same 

Sentence, Line, or Paragraph. If, for example, you wanted GM and Ford within 5 words of one 
another, you would enter "5".

3. Choose a structural unit for the Search (either Words, Sentences, Lines or Paragraphs).
4. Choose a Direction for the Search Condition. Your choices:

· Before
· After
· On Either Side of
· In the Same

This selection defines the proximity of your search. If you select IN THE SAME, both words or 
phrases must occur in the same structure (Sentence, Paragraph, or Line).

5. Enter the second word or phrase of your Search.
6. Choose OK.

askSam will execute the Search and retrieve the first Document meeting your criteria. 

Dialog Box Options

Word or Phrase 1 
Type or select the first word or phrase of the search.

Fuzzy
Click on this option to search for a fuzzy equivalent of the word you enter. For example, a Fuzzy Search 
for "Kathy" would find "Kathy", "Kathi", "Cathy", and "Katey".

Qty
Type a number in the quantity field to define the relationship between the words or phrases in the search. 
Leave the Qty Box blank if you want the words or phrases to appear in the same Sentence, Line, or 
Paragraph.

Structure
Select a structural unit for the search:

Word(s) Defines the search unit as a specified number of Words.

Lines(s) Defines the search unit as a specified number of Lines.

Sentence(s) Defines the search unit as a specified number of Sentences.



Paragraph(s) Defines the search unit as a specified number of Paragraphs.

Direction
Select the direction for the search:

Before Searches for the first word to appear before the second word.

On either side of Searches for the first word to appear on either side of the second word.

After Searches for the first word to appear after the second word.

In the same structure as Searches for the first word to appear in the same specified structure (ie. 
paragraph, sentence etc.) as the second word.

 
 Word or Phrase 2
Type or select the second word or phrase of the search.

Word List Button (only in askSam Professional)
In an indexed file, the Word List button will appear. Choose this button to display a list of the words 
contained in the file.

Max Hits (only in askSam Professional)
In an indexed file, the Max Hits field displays the number of documents that will be retrieved by your 
request.

Proximity Search Options
Click on the Options Button to further modify the Proximity Search.

Proximity Type
Word or Phrase Searches the entire text of each document in the current file.

First word of each document Limits the search to a word or phrase in the first word, sentence, 
line, or paragraph of a document in the current file.

Output Form
Document Outputs the the entire document matching the proximity selection. This is the 

default setting.

Selected Structure Outputs only the structure containing the proximity selection.

_________________
See also

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Sort command (Actions menu)

Use this command to sort documents in the current file in a specified order. You can Sort alphabetically, 
by number, or by date.

Dialog Box Options

Field List
Type or select the name of field you want to use for the Sort.

Field Type
Select the field type.
Text Sorts text in alphanumeric order.

Date Sorts fields containing dates.

Numeric Sorts fields containing numbers.
        
Modifiers
Defines a modifier for the Sort.
Ignore Upper/Lower Case If selected the sort will not be case sensitive.

Descending Places the Sort list in a descending order.

Ignore Articles Ignores the words "A", "An", and "The" when Sorting.

Sort on Last Word Sorts on the last word in a field. Useful with name fields.

Modifiers - Sort Order
List of the fields and modifiers for your sort as you build the sort. 

Add Adds a field and modifier to the end of the Sort List.

Replace Replaces the selected    field and modifier with the field and modifier you enter.

Move Up Moves a field and modifiers up one line

Move Dn Moves a field and modifiers down one line

Clear All Removes all fields and modifiers from the Sort List.

Sort by
Select the Sort criteria you want.

Multiple words in field Sorts a field with multiple words in the Sort field.

First word in field Sorts by the first word in the Sort field.

First word in doc Sorts by the first word in each document in the current file.



Word Search (Multiple Search Request Dialog)

Enter a word or phrase to search for in the current file.



Multiple Search Request command (Actions menu)

Use this command to combine all of askSam's search functions into a single request. The Multiple Search
Dialog Box links the various searches together with Boolean logic. For example, using the Multiple Search
Request, you can construct a search to locate all Documents:

· with a date from August to November 1963
· containing the words "Cuba" or "Soviet Union" in the field Title
· and containing the words "Castro" and "Khrushchev" in the same sentence.

Using the Multiple Search Command

1. Choose the Selection Button for the search type you require (Word, Field, Date, Numeric, or 
Proximity).
The Dialog Box for your selected search type will appear.

2. Enter your search request in the Dialog Box.
3. Choose OK.

You will return to the Multiple Search Dialog Box. The search you entered will appear in the Search 
List.

4. Choose a Boolean Operator - either the AND, OR, or NOT Button.
If no Boolean operator is selected, an AND is understood and used to connect the search requests. 

5. Repeat steps 1, 2, 3, and 4 until your search request is complete.
6. Choose OK.

askSam will retrieve all the Documents meeting your search criteria.

Dialog Box Options

Selection
Defines the search type you want to execute:

Word Searches for a word or phrase.

Field Searches for documents with a specific word or phrase in a specified field.

Date Searches for documents according to a date in a field. The categories of date searches are 
Single Range, Dual Range, and Comparison.

Numeric Searches for documents based on a numeric comparison of fielded information.

Proximity Searches for two words or phrases occurring within a specified proximity of one another.

Search List
Lists the search request as you construct it.

Boolean Operators
Use the Boolean operators, And, Or, Not,    to construct a multiple word search request to search in the 
current file.

Note:    If no Boolean operator is selected, an implied And is used to connect the search request.



Move Up
Click the Move Up button to move the selected item in the Search List to the position preceding it.

Move Down
Click the Move Down button to move the selected item down one position in the Search List.

Clear
Removes the selected item from the Search List.

Clear All
Clears all items from the Search List.

Count selected documents
Counts the number of documents that meet the search criteria.

Max Hits (only in askSam Professional)
In an indexed file, the Max Hits field displays the number of documents that will be retrieved by your 
request.
_______________
See also

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Output Fields command (Actions menu)

Use this command to output the contents of a field.

Dialog Box Options

Field
Type or select the field which contains the information you want to output.



Total Field command (Actions menu)

Use this command to calculate the sum, count and average of numerical data in a field.

Dialog Box Options

Field
Type or select the field you want to total.

Modifiers
Use the Total Field Modifiers to further define the Total Field command.

List Amounts Outputs the total and the number from each field used to calculate the total.

First Value Only When a the specified numeric field occurs more than once in a document, the First 
Value Only options uses only the value in the first field to calculate the total.    The 
default setting uses all the values to calculate the total.



Show command (Actions menu)

With the Show Command, it is possible to output Sentences, Lines, or Paragraphs which contain specific 
words or phrases. For example, you could search through the complete testimony of the Iran-Contra 
hearings for every line containing the phrase "Oliver North".

Using the Show Command

1. Enter the Word or Phrase you wish to locate. 
2. Enter a number in the quantity field.

This number determines how many Words, Sentences, Lines, or Paragraphs will be output.
3. Choose either Words, Sentences, Lines or Paragraphs for the output structure.
4. Choose a Direction. Your choices are: Before, After, On Either Side Of, or Containing.

This selection defines how much text will be output.
If you select CONTAINING, only the Sentence, Line, or Paragraph containing the specified word or 
phrase will be output.

5. Choose OK.
askSam will output the information to a new window. If you double click on any line in this Window, 
you return to the Document containing the information in that line. You can Print, Edit, and Save this 
List as another askSam file.

Dialog Box Options

Word or Phrase
Type or select the word or phrase you want to locate.

Fuzzy
Click on this option to search for a fuzzy equivalent of the word you enter. For example, a Fuzzy Search 
for "Kathy" would find "Kathy", "Kathi", "Cathy", and "Katey".

Quantity
Type a number in the box. This determines how many words, sentences, lines, or paragraphs will be 
output.

Structure
Select a structure for the output:

Word(s) Outputs the specified number of words in the direction you select.

Line(s) Outputs the specified number of lines in the direction you select.

Sentence(s) Outputs the specified number of sentences in the direction you select.

Paragraph(s) Outputs the specified number of paragraphs in the direction you select.

Direction
Determines the direction from the specified word or phrase that is output:

Before word or phrase Outputs the word or phrase immediately preceding the word or 
phrase.



Either side of word or phrase Outputs the word, line, sentence, or paragraph on either side of the
word or phrase.

After word or phrase Outputs the word, line, sentence, or paragraph immediately after 
the word or phrase.

Containing word or phrase Outputs the line, sentence, or paragraph containing the word or 
phrase.

All Occurrences
If checked, the Show Command outputs each occurrence of the word or phrase in your file. If not 
checked, only the first occurrence in each document is output.

Options

Reformat Output Click to output the text formatted within the current margins.    The 
default setting is to output the text as it is stored in the document 
from which it is retrieved.

First Structure of Document Click to output only the first line, sentence, or paragraph of the 
documents containing the specified word or phrase. 



Count Word or Phrase command (Actions menu)

Use this command to count the number of times a specific Word or Phrase occurs in a file.    You can also 
count the number of documents in a file which contain a specific Word or Phrase.

Dialog Box Options

Word or Phrase
Type or select the word or phrase you want to count.

Count All occurrences of word/phrase
Select this option to count all occurrences of the word or phrase in a file. The default setting is to count 
only the first occurrence of the word or phrase.

Count # of Documents with word/phrase.
Select this option to count the number of documents which contain the word or phrase.

___________
See Also

Count Selected Documents (Multiple Search Request command)
Number of Hits



Hyper on Selected command (Actions menu)

Use this command to select a word or group of words and search in the current file for further 
occurrences of this text.

Shortcuts
Keys: Ctrl+Y

_______________
See also

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on File 

Find 
Repeat Last Find 



Hyper on File command (Actions menu)

Use this command to select a word or group of words and search in any open askSam file for documents 
containing these words.

Shortcuts:
Keys: Ctrl+F

Dialog Box Options

Current Open File(s)
Select the open files in which you want to conduct the Hypertext Search.

_______________
See also

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 

Find 
Repeat Last Find 



Word List command (Actions menu)

Note: The Word List is only available in the askSam Professional version.

Use the Word List to display a list of every word in an indexed file. Just click and search for any word in 
the list

Using the Word List

1. Start typing the word you wish to find.
The Word List will scroll as you type.

2. Choose the GOTO button when the word you want to find is selected.

askSam will retrieve the first document containing the word or words you entered. The status bar at 
the bottom of the screen will display the total number of hits for this search.

NOTES:
1. The number of hits displayed in the Word List indicates the number of Documents containing a word.

It does not count the total occurrences of the word in your file. Use the ACTIONS -> COUNT WORD 
OR PHRASE command to count the total occurrences of a word or phrase in your file.

2. After a file is indexed, a Word List button will appear in the Boolean, Search In Field, and Proximity 
Search dialogs. If you select this button, the word list will appear.

3. After text is deleted, the Word List may contain words which are no longer in the file. Packing 
updates the Word List while it compresses and optimizes your file.



Set Hypertext Link (Document Menu)

Hypertext links can be set to other documents, reports, files, applications or commands. To set a 
Hypertext Link to another location, you must define a Bookmark at this location. The Bookmark gives your
destination a name that Hypertext can link to. To set a Bookmark, you place the cursor in the line where 
you want the Bookmark and choose DOCUMENT -> SET BOOKMARK. Enter a name for the Bookmark 
and choose OK.

Shortcuts:
Keys: F4

Dialog Options

Link To:
Current Document Sets a Link to a Bookmark in the current Document.

Current File Sets a Link to a Bookmark in the current File.

Other File Choose this option and then choose the Browse button to select another 
askSam File. You can set a Link to a Bookmark in this File.

Reports in Current File Sets a Link to a Report in the current File.

Reports in Other File Choose this option and then choose the Browse button to select another 
askSam File. You can set a Link to a Report in this File.

Menu Commands Sets a Link to any askSam Menu Command.

External Application Defines a link from askSam to an external application.

HTML URL Lets you create HTML documents which contain links to other sites on the 
Internet.

You can set a Hypertext from a selected text or a selected graphic. After a Hypertext Link is set, the 
selected text turns green and underlined. It is now linked. By clicking on it, you jump to the Bookmark, run
the Report, or execute the Menu Command.

Deleting a Hypertext Link
There are two ways to remove a Hypertext Link.:

· Delete a Hypertext Link by deleting the green underlined word or phrase from your Document. 
Select the word or phrase and press the DEL key.

· Delete a Hypertext Link but leave the text by selecting the green underlined word, choosing 
DOCUMENT -> SET HYPERTEXT LINK, and selecting the UnLink button.

NOTE: To select (highlight) a Hypertext Link, use the keyboard, not the mouse. If you click with the
mouse to select a Link, you execute the link. Also, only select the Link or part of the link. If a 
selection includes unlinked text, the UnLink button is not available.

NOTES:
1. You can set multiple Hypertext Links to a single Bookmark. For example, if you have a Bookmark 

called "Table of Contents", you can have Hypertext Links in several different places that jump back to
this Bookmark.



2. To edit an existing Hypertext Link, select the green underlined word or phrase and redefine the Link 
by choosing DOCUMENT -> SET HYPERTEXT LINK. 

3. You can set the color in which your Hypertext Links are displayed. Choose OPTIONS -> GLOBAL 
PREFERENCES -> COLORS. 

4. You can define whether a Single Click or Double Click executes a Hypertext Link. Choose OPTIONS
-> GLOBAL PREFERENCES -> HYPERTEXT.

_______________
See also

Set Bookmark (Documents Menu)
Bookmarks (View menu)
Hypertext Link (View Menu)



Set Bookmark (Document menu)

Use this command to set a bookmark in a line of a document.

Shortcuts:
Keys: F2

Dialog Box Options

Bookmark Name:
Enter a name for the Bookmark. Bookmark names can contain letters and numbers. A name may also 
consist of multiple words.

Current Bookmarks
Displays a list of current bookmarks.

Delete
Deletes a bookmark

NOTE: A bookmark is set in the current line. A file may contain an unlimited number of Bookmarks. 
Each Document in a file may contain up to 256 Bookmarks.

_______________
See also

Bookmark (View menu)



View Deleted Documents command (Document menu)

Use this command to view the documents that were deleted from the current file.    When a document you 
want to restore to the file is on the screen, use the Undelete command (Document menu).

Note:    Packing a file permanently deletes a document. After packing a file cannot be undeleted.



Phone Dialer command (Tools menu)

Use this command to automatically dial a selected (highlighted) phone number.

Shortcut
Toolbar:  

Keys: Ctrl+R

To Automatically Dial a Phone Number
1. Select (highlight) a phone number.
2. Choose TOOLS -> DIAL PHONE NUMBER (or press Ctrl+W).
3. Select a dialing suffix (if necessary).
4. Choose OK

askSam will dial the selected phone number.

_______________
See Also

Phone Dialer Setup



Add command (Document menu)

Use this command to add a blank document to the current file.

Shortcuts
Toolbar:  

Keys: Crtl+A

_______________
See Also

Add w/ Entry Form command (Document menu)
Adding a Document (Step-by-Step Instruction)



Add w/Entry Form command (Document menu)

Use this command to add a document with a predefined Entry Form to the current file.

Shortcuts
Toolbar:  

Keys: F5

_______________
See Also

Entry Form



Add Duplicate command (Document menu)

If you need to add several documents with similar content use the Add Duplicate command. 

Using the Add Duplicate command

1. Go to the document you want to duplicate. 

2. Choose DOCUMENT -> ADD DUPLICATE.
 A copy of the current document is created. 

_______________
See Also

Add w/ Entry Form
Add



Pick List command (Document menu)

Pick Lists simplify entering data in askSam. With a Pick List you define a list of entries for a field. When 
you enter data in that field, you can have the list automatically appear, or you can simply press a key and 
display the list. Then choose the entry you want to insert in the field.

With askSam you can define a Pick List for a specific field, or you can define a Global Pick List for a file.

Field specific Pick Lists are useful for keyword fields, classification fields, any field where you have a 
limited number of options to enter. 

Global Pick Lists are helpful for long words or commonly used phrases (such as company name). With a 
single keystroke you can access this list and insert the desired information.

This help screen describes entering data with a Pick List. For information on creating a Pick List, see Edit 
Pick List.

Entering Data with a Pick List

1. Choose DOCUMENT -> PICK LIST (or press F11).
The Pick List dialog box will appear. 

NOTE: The Pick List dialog box will only appear if you've already defined either a Global Pick List or 
a Pick List for the current field. If no Pick List is defined, the Edit Pick List dialog box will appear.

2. Select the Pick List entry you want to insert and choose OK.

The Pick List entry will be inserted at the current cursor position.

NOTES:
1. If you wish to select multiple entries from the Pick List, simply click on each of the entries and then 

choose OK. Each of the selected entries is inserted at the cursor position.

2. If the Auto Popup option is selected, your Pick List will automatically appear when you enter the field.

Dialog Box Options

Add/Edit Button
accesses the Edit Pick List dialog. From this dialog you can:

· Add new entries to the Pick List.
· Modify existing entries in the Pick List.
· Define a Pick List for another field.
· Delete entries in the Pick List.

Popup Pick Lists

If you choose the Auto Popup option for a Pick List, the Pick List automatically appears when you reach 
the field. When a Popup Pick List appears you can:



· choose an entry from the Pick List and press ENTER to insert it.
· select multiple entries from the Pick List and press ENTER to insert them.
· press ESC to remove the Pick List.

NOTE: A Popup Pick List only appears when adding a new Document with Data Entry mode on. When 
you later return to edit a Document, you must press F11 to display the Pick List.



Edit Pick List

Pick Lists simplify entering data in askSam. With a Pick List you define a list of entries for a field. When 
you enter data in that field, you can have the list automatically appear.

You can define a Pick List for a specific field, or you can define a Global Pick List for a file. Field specific 
Pick Lists are useful for keyword fields, classification fields, any field where you have a limited number of 
options to enter. Global Pick Lists are helpful for long words or commonly used phrases (such as 
company name). With a single keystroke you can access this list and insert the desired information.

This help screen describes creating a Pick List. For information on entering data using a Pick List, see 
Pick List.

Defining a Pick List

1. Choose DOCUMENT -> PICK LIST (or press F11).
The Edit Pick List dialog box will appear. 

Note: If you've already defined a Pick List, the Pick List dialog will appear. You will need to select the
Add/Edit button to access the Edit Pick List dialog box.

2. Choose whether your Pick List is for a specific field or global.

At the top of the Edit Pick List dialog is the Field Setting. Here you define the field for your Pick List, 
or you choose to have a global Pick List.

Note: A list of field names will only be displayed if you have created an Entry Form and entered 
fields.

3. Enter the text for your Pick List and choose Add. The text will be inserted in the Pick List.

At times you may want a description displayed in the Pick List and an abbreviation inserted in your 
field. For example: the description in the Pick List could be "Massachusetts". The text inserted could 
be "MA".

To do this, enter your description (e.g. Massachusetts). Before choosing Add, type the text you want 
inserted (e.g. MA) in the "Text to be entered" field at the bottom of the dialog. Then choose the Add 
button. The descriptive text is displayed in the Pick List, but the abbreviation will be inserted in the 
field.

4. Choose OK when your Pick List is complete.

The Pick List dialog box is displayed. You can select any item in the Pick List and choose OK to 
insert it in your file. Or you can choose Cancel to remove the Pick List from your screen.

NOTES: 
1. You can include commands to insert date, time, weekday, and a carriage return in your Pick List.

^D inserts the current date.
^E inserts a carriage return (only in multiline fields or when data entry mode is off).
^T inserts the current time.
^W inserts the weekday.



2. The ^E command can be used to generate multiple line output from a Pick List. For example, you 
could have a Pick List Entry called "Closing" with the text:

Sincerely,^E^EJohn A. Smith^EPresident^EABC Corporation

This would insert:

Sincerely,

John A. Smith
President
ABC Corporation

The ^E command will only function in a multiple line field, or when data entry mode is off.

3. The size of your Pick Lists is limited to 32K per file.

Dialog Box Options

Field
Determines which field the Pick List is defined for. You can select a specific field, or you can define a 
Global Pick List. 

Sort
Alphabetically sorts the contents of the Pick List.

Auto Popup
Select the Auto Popup option if you want your Pick List to automatically appear when you enter the field. 
The Auto Popup option is only active when Data Entry mode is on and before a Document is saved. Once
you save a Document, you will have to press F11 to display the Pick List for a field.

Pick List Description
Enter a description of the Pick List entry.

Add
Adds new entries to the Pick List. Enter the description / text you want and choose the Add button.

Delete
Deletes an existing entry. Selecting the entry and choosing the Delete button. To delete multiple entries 
from a Pick List repeat this for each entry you wish to delete.

Replace
Replaces an existing entry with a new text. Select the entry you want to replace, enter the new text, and 
choose the Replace button.

Text to insert
At times you may want a description displayed in the Pick List and an abbreviation inserted in your field. 
For example: the description in the Pick List could be "Massachusetts". The text inserted could be "MA".
_______________
See Also

Pick List



Delete command (Document menu)

Use this command to remove the current document from your file.    To undelete a document, use the 
Undelete command (Document menu).

_______________
See Also

Delete Selected Documents
Delete Duplicates
Undelete
View Deleted Documents



Delete Selection command (Document menu)

Use this command to remove multiple documents from the current file.    To undelete documents, use the 
Undelete command (Document menu).

Dialog Box Options

You select the documents you wish to delete with the Multiple Search dialog box. See Multiple Search 
Request (Actions menu).

View Deleted Docs
If checked, askSam will provide a chance to view the documents. You can choose to delete or not delete 
each document.

_______________
See Also

Delete a Document
Delete Duplicates
Undelete
View Deleted Documents



Delete Duplicates (Document Menu)

The Delete Duplicates command simplifies finding and deleting duplicate documents in your file. You 
define which field or fields should not have duplicate entries, and askSam displays any documents where 
duplication occurs. You then have the option of deleting the duplicate documents.

Dialog Options

Select Fields
A Dialog Box will appear in which you define the field or fields which should not contain duplicate 
information in any two documents (for example Name and Phone fields, or the Title and Author fields).

Field List List of fields available in the file.

Add Selects the fields that should not contain duplicate information from the Field List.

Unique Fields List of fields selected that should not contain duplicate information.

Replace Replaces a field in the Unique Field list with the field you select.

Move Up Moves a field up one line in the Unique Field list

Move Dn Moves a field down one line in the Unique Fieldslist

Clear All Clears all fields from the Unique Fields list

Duplicates
askSam searches your file for duplicates. If duplicates are found, the first duplicate document will be 
displayed. The Retrieval Dialog Box appears, and you can move through the duplicate documents by 
choosing Next and Previous. Choose Delete to delete Documents from your file.

_______________
See Also

Delete 
Delete Selection 
View Deleted Documents 
Undelete 



Undelete command (Document menu)

Use this command to restore a deleted document to the current file.    To view the documents deleted in 
the current file, use the View Deleted Documents command (Actions menu).



Tag command (Document menu)

Use this command to remember a document in the current file for quick retrieval.

Note:    To retrieve the tagged document, choose the Go to Tagged command (View menu).

Shortcuts
Toolbar:  

________________
See also 

Go to Tagged command (View menu).



Data Entry command (Document menu)

Use this command to switch between Data Entry Mode and Word Processing Mode. When in Data Entry 
Mode the word DATA will appear in the status bar.

Shortcut
Keys: Ctrl+E

Data Entry Mode & Word Processing Mode
You have a choice of two modes for entering information into a Document.    You can enter information in 
the very freeform Word Processing Mode, or you can use the Data Entry Mode for more structured 
information.

Word Processing Mode
Like any Word Processor, you can move freely around the screen, editing text and formats. 

Data Entry Mode
This mode is designed to simplify entering data. When active, pressing ENTER or TAB moves you from 
one field to the next. Your movement in the Document is restricted to fields.

In Data Entry Mode...
1. You can only enter data into fields - the area between the beginning and closing brackets.

Example:    ZIPCODE[                      ] 
Here you would only be permitted to type between the brackets.

2. You cannot edit field names or change the length of a single-line Field.

3. If no closing bracket marks the end of a field, text added to this field will not wrap to the next line. It 
will stop at the right margin. 

4. Define a multi-line field by placing a closing bracket at least one line beneath the field name. Text 
automatically wraps in a multi-line field, and the field expands as you enter information. Pressing 
ENTER in a multi-line field inserts a blank line.

5. You cannot Cut or Delete selected text, if a field name is also selected.

6. You cannot Drag and Drop text in Data Entry Mode.

Moving the Cursor in Data Entry Mode ...
· Pressing TAB moves you to the next field.

· Pressing ENTER moves you to the next field or inserts a line in a multi-line field.

· Pressing SHIFT+TAB or UP ARROW moves the cursor to the previous field.

· The HOME key moves the cursor to the beginning of a field or to the beginning of a line in a multi-line 
field.

· The END key moves the cursor to the last character of a field or to the end of a line in a multi-line 



field.



Line Spacing (Format Menu)

Sets the spacing between lines of text.

Options
Single Spacing (default setting)
1.5 Spacing 
Double Spacing 



Tabs (Format Menu)

Use this command to define the tabs for the selected text or the line containing the cursor. To remove a 
tab, select the tab in the Tab Stop Position list and click the Clear Button.

Shortcuts:

Left  

Center  

Right  

Decimal  

Dialog Box Options

Tab Stop Positions
Type a measurement for the tab you want to define in the current document.

Alignment
Select the justification for the tab.
Left Justifies the text on the left tab margin.
Center Center justifies the text.
Right Justifies the text on the right tab margin.
Decimal Justifies the numeric text on the decimal point.

Set
Defines the tab with the setting you selected.

Clear
Removes the selected text from the Tab Stop Position list.

Clear All
Removes all text from the Tab Stop Position list.

_________________
See Also

Setting Tabs (Step by Step Instructions) 
Left Tab 
Center Tab 
Right Tab 
Decimal Tab 



Indents (Format Menu)

Indents can be set on either the left or right side of the page. You can indent the first line of a paragraph, 
or you can define a hanging indent. Indents may be set on a line-by-line basis.

Dialog Options

Left
Enter your left indent setting

Right
Enter your right indent setting

Type
None Indents all selected lines
First Line Indents only the first line
Hanging Indents all lines but the first line

By
Defines the number of inches for First Line or Hanging indents

NOTE: Margins and Indents are similar, but they serve different purposes. Margins are set for an 
entire Document, whereas Indents can be set on a line-by-line basis. Indents are displayed on 
screen. Margins are not displayed, they only affect printing. Generally, margins are used when 
you print on different size paper, stationary, or labels. Indents are used to format documents.



Font command (Format menu)

Use this command to define the font type, font size, font style, and color for the selected text or the text 
entered at the cursor position.

Dialog Box Options

Font
Type or select the Font that you want to use.

Font Style
Type or select the Font style that you want to use (bold, italic, bold italic).

Size
Type or select the size of the Font you want to use.

Effects
Type or select the Font effects you want to use (strikeout, underline).

Color
Type or select the color you want to use.

Sample
Displays an example the Font type, style, size, effect, and color that you selected.



Alignment command (Format menu)

Use this command to align the selected text or the text entered at the cursor position. You can align text 
on either the left margin, right margin, or centered between the two margins.

Shortcut

Toolbar:
Left  

Center  

Right  

Sub-menu Options

Left
Aligns the text on the left margin.

Centered
Aligns the text between the left and right margins.

Right
Aligns the text on the right margin.



Subscript (Style Sub-menu)

Changes the highlighted text to subscript.

______________
See Also

Superscript (Style Sub Menu)



Superscript (Style Sub-menu)

Changes the highlighted text to superscript.

______________
See Also

Subscript (Style Sub Menu)



Style command (Format menu)

Use this command to define the font style for the selected text or the text entered at the cursor position.

Sub-menu Options
Normal
Defines the text as normal script. Example: Sample Text

Bold
Defines the text as bold script. Example: Sample Text

Italic
Defines the text as italic script. Example: Sample Text

Underline
Underlines the text. Example: Sample Text

Strikeout
Strikes through the text. Example: Sample Text

Superscript
Makes the text a superscript. 

Subscript
Makes the text a subscript



Color command (Format menu)

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Single Line Spacing command (Format menu)

Use this command to define the line spacing for the selected text or the text entered at the cursor position
(single, 1.5, and double).    The default setting in askSam is single spacing.

Shortcut
Toolbar:  

Sub-menu Options
Single
Defines the line spacing for the text as single space.

1.5 Lines
Defines the line spacing for the text as 1.5 lines.

Double
Defines the line spacing for the text as double.

_______________
See also

1.5 Line Spacing command (Format menu)
Double Line Spacing command (Format menu)



Set Page Break command (Format menu)

Use this command to set a manual page break at the cursor position.    To remove a manual page break, 
use the Remove Page Break command.

____________
See also

Breaking Documents into Pages (Step-by-Step Instruction)



Remove Page Break command (Format menu)

Use this command to remove a manual page break.    

To remove a page break, position the cursor immediately above the page break and select Remove Page 
Break from the Format menu.

Note:    To insert a manual page break, use the Set Page Break command (Format menu).
____________
See also

Breaking Documents into Pages (Step-by-Step Instruction)



Repaginate command (Format menu)

Use this command repaginate the current document. When you choose the Repaginate command, 
askSam will display a line where a page break will be inserted.

To change the placement of an automatic page break, insert a manual page break before the automatic 
page break and repaginate the document.

Note:    askSam does not automatically display page breaks before printing.    To ensure that the page 
breaks on the screen match those in the actual printout, use the Repaginate command before printing.
____________
See also

Breaking Documents into Pages (Step-by-Step Instruction)



Left Tab command (Format menu)

Use this command to define a left tab for the selected text or the line containing the cursor. When set and 
the tab key is selected, text is left justified at the tab position.    

Shortcuts
Toolbar:  

To set a left tab
Place the cursor on the line where you want a left tab. Click on the left tab button in the format bar. Click 
on the position in the ruler where you want a left tab. The left tab is set for the line where the cursor is 
currently located.

To remove a tab setting
Select the tab on the ruler with a mouse and drag it off the ruler.

____________
See also

Tabs (Format Menu) 
Right Tab 
Center Tab 
Decimal Tab 



Colors (Global Preferences)

Sets default background, foreground, and Hypertext colors

1. Choose OPTIONS -> GLOBAL PREFERENCES -> COLORS
The Colors Dialog Box will appear.

In this menu you can set the default:
· Foreground Color
· Background Color
· Hypertext Color

2. To set a color, choose either Foreground, Background, or Hypertext, and then click on the color you 
want for this option. Repeat this for the other two colors. The sample text will display the color 
scheme you've selected. 

3. Choose OK when complete.

NOTES:
1. The Foreground and Background color of a specific word or text passage can be set in the FORMAT

-> FOREGROUND COLOR or FORMAT -> BACKGROUND COLOR menu. The purpose of the 
Colors menu in the Global Preferences dialog is to let you define a default color screen for all of your
askSam files.

2. Setting the Background and Foreground color will not affect any texts you've formatted using the 
FORMAT -> COLOR commands. It only changes new files and files in which you have not previously
set colors.

_________________
See Also

Global Preferences (options menu)



HTML Options (Global Preferences)

Hypertext Options (Global Preferences)
The HTML button in the Global Preferences menu defines Import and Export settings for the HTML filter.

Import Options

Import Graphics
Determines whether askSam tries to import graphics when importing HTML files. Since graphics require 
significant space, it is often advantageous to import information without importing the graphics.

Netscape Browser Directory
When you save an HTML document from a browser (such as Netscape), the text and formats from the 
HTML document are saved. The graphics are not downloaded to your system. To simplify getting 
graphics, askSam automatically checks your Netscape directory. If it contains the graphics, askSam will 
include them in the imported documents.

The Netscape Browser Directory tells askSam what directory contains your Netscape Browser.
If you are not using Netscape, you can still import graphics with your HTML Documents. You will have to 
download the graphics and place them into the same directory as the HTML file you want to import.

Export Options

Internet Domain Site for Hypertext Links
When you export an HTML Document from askSam, askSam needs to know your domain in order to 
properly export Hypertext Links to other files. 

Graphic File Format
This setting determines the format of graphics exported with HTML Documents. You can choose either 
GIF or JPEG.

_________________
See Also

Global Preferences (options menu)
Creating HTML Documents
Importing HTML Documents



Hypertext Options (Global Preferences)

The Hypertext Options affect askSam's Hypertext functions.

Status bar options
When the mouse cursor points to a Hypertext Link, askSam displays information in the Status Bar. The 
Status Bar option determines what askSam displays:

No Text Nothing is displayed in the Status Bar.

Link name only Displays the name of the link (ie. Bookmark or report name) in the Status Bar.

Filename and link Displays the name of the link (ie. Bookmark or report name) and the name of the 
file containing the link.

Use a single mouse click to activate links
If selected, a single click will activate a Hypertext Link. If not selected, a double click is necessary to 
execute a Hypertext link.
_________________
See Also

Global Preferences (options menu)
Set Hypertext Link



Number and Currency Formats (Global Preferences)

Number
Sets the format for numbers in totals and subtotals.

1000 Separator
Select the character to separate thousands (ie. select comma to have 1,000)

Decimal Separator
Select the character to separate decimals (ie. select a period to have 200.05)

Currency
Changes the currency symbol and placement.

Symbol Placement
Select style of currency display (ie. $1, 1$)

Symbol
Select currency symbol (ie.    DM, £ )

_________________
See Also

Global Preferences (options menu)



Sort Table (Global Preferences)

Customize the sort order of characters.

Default
Use the default askSam sort table

User Defined
Use a customized sort order. You can change the order of the characters in the table to suit your 
requirements.

_________________
See Also

Global Preferences (options menu)



Customize Button Bars (Options Menu)

Define the buttons you want to include in the format bar and tool bar.

Button Bar
Choose either Format Bar or Tool Bar. Buttons currently on the chosen button bar will appear below.

Available Commands
These are buttons available for you to add to the Format or Tool bar.

Add
Adds the selected button to the end of the Format or Tool Bar.

Replace
Replaces selected Button in the Format or Tool Bar with the button from the Available Commands.

Insert
Adds a button from available Commands to Format or Tool Bar above the selected button.

Delete
Removes a selected button from the Format or Tool Bar.

Default
Sets the Format or Tool Bar back to its original setting.

_________________
See Also

Tool Bar
Format Bar



File Preferences command (Options menu)

The File Preferences Dialog Box contains options which can be defined for the current file. 

Dialog Box Options

HIGHLIGHT COLORS
Foreground Color Sets the foreground color for matches displayed with askSam retrieves a 

document.
Background Color Sets the background color for matches displayed with askSam retrieves a 

document.

FILE FONT
Defines the default font used by all Documents contained in a file. (It will not affect fonts specified using 
the FONT Dialog Box or the drop-down Font Menu.)

TURN ON DATA ENTRY
If checked, Data Entry Mode will be active for your file. 

SAVE AS DEFAULTS
Check this option if you want to save the current File Preference settings as default settings for new files.

CASE SENSITIVE SEARCHES
If checked, all searches are case sensitive. The case of the word you enter in a Search must match 
exactly the case of the word in the Document.

FUZZY SEARCH
If checked, all searches from the Command Line use Fuzzy Logic. See Fuzzy Search.

SHOW ALL MATCHES
If checked, all occurrences of the word you searched for are highlighted. If unchecked, only the first 
occurrence in a Document is highlighted. This setting also affects field output. If the same field occurs 
multiple times in a Document, it will be output multiple times when this option is checked.

DOCUMENT COUNTER
The ^N command can be inserted into an Entry Form to number Documents as they are added. The 
Document Counter allows you to reset the number of the next Document added to your file. 

FIELD CHAR
Defines which character designates a field. The default setting is the character [ (open square bracket). 
Words ending with this character are treated like fields. For example, Name[ or Fax[. If your information 
contains words ending in another character, and you wish to use these words as fields, define this 
character as the Field Character. For example, if you have a file containing E-Mail and want to use words 
such as To:, From:, and Date: as fields, enter a : (colon) as the Field Character.

ADD NEW DOCS TO
End of File New documents will be added to the end of the current file.
Top of File New documents will be added to the beginning of the current file.
After Current Doc New documents will be added after the current document.

RULER SETTINGS
Sets default values for the Left and Right Ruler Markers. You can also set Indents. These settings will 



only affect New Documents added or imported to your file (not your existing Documents).

INDEX OPTIONS (only available in askSam Professional)
Affect the size, speed, and contents of your index. See Index Options.

________________
See also

Global Preferences 
Fuzzy Search
Index Options



Index Options

The Index Options affect the size, speed, and contents of your index. They are set on a per file basis.

Modifying the Index Options

1. Choose OPTIONS ->    FILE PREFERENCES
The File Preferences dialog box will appear.

2. Select the Index Options button.
The Index Preferences dialog box will appear.

Dialog Box Options

Index Single Character Words
If checked, single character words (not defined as Noise Words) will be included in the index. As a default
setting, single character words are not indexed.

Index Field Names
If checked, the field names in your database are included in the index. Field names are any words ending 
with the field character (normally the opening square bracket [ or    the colon :. Since field names normally 
appear in most documents, the default setting does not index field names. 

Punctuation Characters
The Punctuation Characters option defines characters to remove from words when a file is indexed. For 
example, normally you would not want the word Goodbye as one entry in your index and the word 
Goodbye! as another entry. Since the exclamation point ( ! ) is defined as a punctuation character, 
"Goodbye" in our previous example would appear as a single entry in the index.

The default punctuation characters are !@#$%^&*()+=~`{}[]|\:;"<>?,./

You can insert new characters or delete any of the existing characters from this list.

Buffer
The buffer setting defines the buffer size for indexing. In general, a larger buffer increases performance 
during indexing. The buffer is only used while askSam is indexing a file. Once indexing is complete, the 
buffer memory is freed.

Noise Words
The Noise Words option lets you enter words which you do not want included in the index. This is used 
for words such as "the", "an", and "in" - words that frequently appear in documents but would not be 
useful terms to search for.

You can insert new words or delete any of the existing words from this list. The size of the Noise Word list 
is limited to 1600 characters.
________________
See also

Indexing



Password/Encrypt command (Options menu)

Use this command to prevent access to your files with password protection and text encryption.    To 
remove a password or text encryption, use the Password/Encrypt command.

Dialog Box Options

File Lock Password
Locks the current file to prevent unauthorized access with a password.    Also allows you to edit or remove
an existing password.    The Set Password Dialog Box will appear. 

File Edit Password
Locks the current file to prevent editing, but allows read-only access.    Also allows you to edit or remove 
an existing password.    The Set Password Dialog Box will appear (See above).

Encrypt File
Encrypts the text of the current file to prevent access.    To remove the file encryption protection, reselect 
the Encrypt File option in the Security Dialog Box.

Set Password
Click here to type new passwords or replace old password

Set Password Dialog Box
Old Password To edit an existing password, type the existing password to obtain access to

the file.

New Password Type in a new password to replace the existing password.

Retype Password Retype the password you want to define for the file, either the existing 
password, or the new password. To verify the password



Date/Time Formats command (Options menu)

askSam allows you stamp the date, time, and weekday into your Documents. The Date/Time Format 
Dialog Box lets you define the format to use for stamping this information into your Documents.

Dialog Box Options

Date Format
Defines the date format for the current file

Short If checked, you may select a short date format for the current file.
MDY 08-18-94
DMY 18-08-94
YMD 94-08-18

Separator Select a date separator: \ (08\18\94), - (08-18-94)

Long If checked, you may select a long date format for the current file.
Aug 18, 1994
August 18, 1994
18 Aug 94
18 August 1994

Day Select a day format for the current file.
Long Thursday
Short Thur

Time Format
Defines the time format for the current file.

12 Hour Defines the time format in hour and minute values (12:00 AM -11:59).

12 Hour w/Seconds Defines the time format in hour, minutes, and seconds values (12:00.00 AM - 
11:59.59).

24 Hour Defines the time format in 24 hour values (00:00.00 - 23:59.59).

Save as Defaults
If checked, the settings specified for Date\Time formats will register as default settings.



Output Separator command (Options menu)

Use this command to define a separator that will be output between documents when printing and 
generating Reports.

Dialog Box Options
Define the document separator you want to use.
Line(s) between Docs Defines a specified number of lines as the separator.    Enter the 

number of lines you want to use.
A line of the character Defines a character as the separator.    Enter the character you want 

to use.
A page break between Docs Defines a page break as the separator.

No separator No separator is output between documents. This is the default setting.

Note: To change a separator for a specific report, use the Output Separator option in the Report Settings 
Dialog Box.



Global Preferences command (Options menu)

The Global Preferences Dialog Box allows you to modify askSam's default system settings.
Specific settings can be set for each file by using the File Preferences command.

Dialog Box Options

Show Commands from Dialogs
The Search Requests generated by the Dialog Boxes in the Actions Menu can also be entered directly on 
the Command Line. If you wish to see the Commands that the system generates, turn this option on. The 
requests generated by reports are also displayed before the report is run. The default setting for this 
option is OFF.

Warning Beep
Activates or deactivates the Warning Beep. The Warning Beep is heard in conjunction with various 
messages. The Default setting is ON.

Save BackUp File Before Packing
When you pack a file, a copy is made of the file you are packing. It receives the extension .BAK. If a .BAK
file already exists, the .BAK file is renamed to a .SAV file. If you do not want .SAV files, turn this option off.
The Default setting is ON.

Save document when adding with Entry Form.
This option controls whether the Current Document is automatically saved when you add another 
Document containing an Entry Form. This simplifies entering data.    The Default setting for this option is 
ON.

Activate Text Drag and Drop
Controls whether Drag and Drop editing is active. Drag and Drop text offers a simple method for moving 
and copying selected texts within a Document. The Default setting for this option is ON.

Print each document on a separate page
If selected, each Document will print on a separate page whenever you print multiple Documents.

Keep documents together when printing reports
When you print a report containing information from multiple documents, this option prevents Documents 
from printing on separate pages. 

Automatic Save Every ?? Minutes
Automatically saves all open files at a specified interval.

Measurement Units
Sets the Ruler and all Measurements in either Inches or Centimeters.

Fuzzy Tolerance
Specifies the degree of accuracy required by a Fuzzy Search. 

Colors
The Color button sets the default background, foreground, and hypertext colors. Setting the Background 
and Foreground color will not affect any texts you've formatted using the FORMAT -> COLOR commands.
It only changes new files and files in which you have not previously set colors.



HTML
The HTML button lets you set options for HTML import and export.

Hypertext
The Hypertext button lets you set options for clicking and displaying Hypertext Links. 

Numeric
Sets the currency symbol and numeric format used in totals and subtotals.

Sort Table
The Sort Table lets you define a customize order for the Sort command. Place the characters in the order 
you want them sorted.

________________
See also

File Preferences 
Colors
HTML Options
Hypertext Options
Number & Currency Format 
Sort Table 
Network Version 
Fuzzy Search



Phone Dialer Setup (Phone Dialer Options menu)

Use this command to setup the askSam phone dialer feature for your particular computer.

To access the Phone Dialer Setup:
1. Select (highlight) a phone number.
2. Choose TOOLS -> DIAL PHONE NUMBER (or press Ctrl+W)
3. Choose the Options button.

The Setup Phone Dialer dialog box will appear.

Dialog Box Options

Modem Port
Select the proper modem port for your system

Dial Type
Select the proper dial type.

Tone Sets tone as the dial type.    This is the default setting.

Pulse Sets pulse as the dial type.

Dialing Prefix
Type the long distance codes, international access number, or prefixes and suffices for outside lines that 
must be added to the number you want to dial in the current file.
Add Adds the typed number to the end of the Dialing Prefix List.

Replace Replaces the selected item in the Dialing Prefix List with the item typed number.

Delete Deletes the selected item in the Dialing Prefix List.

Move to Top Moves the selected item in the Dialing Prefix List to the position immediately 
preceding it.

_______________
See Also

Phone Dialer



Always on Top command (Options menu)

Use this command to keep the askSam window on top of the screen when you have several Windows 
applications open.



Generate List (Auto Field Recognition)

This dialog displays a list of fields recognized in your file. 

Selected Fields List of fields you choose to add to the Entry Form.

Available Fields List of possible fields found in the database.

Add Add a field from the Available list to the Selected List.

Add All Add all fields from Available List to the Selected List.

Replace Replace a field in the Selected List with a field from the Available List

Insert Insert a field from the Available List above a field in the Selected List

Remove Remove a field from the Selected List

Choose OK to add the Selected Fields to your askSam Entry Form.

________________
See also

Automatic Field Recognition



Auto Field Recognition (Tools Menu)

Auto Field Recognition searches through an askSam file and displays a list of fields names. You choose 
the valid field names from this list, and askSam inserts them into the Entry Form.

What Character Defines a Field
Enter the character which identifies fields in your file. This tells askSam that words ending with this 
character may be fields. 

List Fields Recognized In
Choose the number of Documents askSam should scan looking for fields. If the fields in your file are the 
same in all Documents, leave this option set for 2 Documents (it speeds up the process). If the field 
structure varies in your Documents, choose the ALL DOCUMENTS option.

Generate List
This dialog displays a list of fields recognized in your file. 

Selected Fields List of fields you decide to add to the Entry Form.
Available Fields List of possible fields found in the database.
Add Adds a field from the Available list to the Selected List.
Add All Adds all fields from Available List to the Selected List.
Replace Replaces a field in the Selected List with a field from the Available List
Insert Inserts a field from the Available List above a field in the Selected List
Remove Removes a field from the Selected List

Choose OK to add the Selected Fields to your askSam Entry Form.



Spelling (Tools Menu)

Check the spelling of a document or a selected text.

Shortcut
Keys: F7

Toolbar:  

To Spell Check an Existing Document:
1. Go to the Document you want to Spell Check. 

If you don't want to Spell Check the entire Document, select the text you want checked.
2. Choose TOOLS -> SPELLING (or press F7).

 askSam will begin checking the spelling in your Document. If askSam encounters a word it does not
recognize, the Spelling Dialog Box will appear.

Spelling Dialog Options

Not In Dictionary Highlighted word was not found in the dictionary. Options follow.

Change To Word entered here will be replaced over incorrect word

Suggestions A list of similarly spelled words that serve as corrections to the incorrect word.

Change Changes the spelling of the unrecognizable word to the alternative that askSam 
suggests or to the alternative that you enter.

Ignore Ignores this word (in this instance and any other instances encountered in this 
Document). The Spell Check continues.

Add To Dict Adds the unrecognizable word to your User Dictionary. When a word is added to 
the User Dictionary, it will no longer be displayed as an incorrect spelling.

After askSam completes the spell check, a message will appear stating how many words were checked 
and how many were spelled incorrectly.

__________________
See also

Auto Spell Check 



Auto Spell Check (Tools Menu)

If selected, askSam will check your spelling as you type.

__________________
See also

Spelling 



Print Mail Merge (Tools Menu)

Prints a Mail Merge Letter

Dialog Options

Selection
Lets you send letters to a selected group of addresses. The Multiple Search dialog will appear. Enter a 
Search request to select the addresses for this letter and choose OK.

Sort
Lets you sort the letters in a particular order. The sort dialog will appear. Define a sort order and choose 
OK.

Print the letter
Highlight a letter to Print and choose OK.
__________________
See also

Create/Edit Mail Merge Letter 
View Mail Merge 



View Mail Merge (Tools Menu)

Previews a Mail Merge Letter.

Dialog Options

Selection
Lets you send letters to a selected group of addresses. The Multiple Search dialog will appear. Enter a 
Search request to select the addresses for this letter and choose OK.

Sort
Lets you sort the letters. The sort dialog will appear. Define a sort order and choose OK.

View the letter
Highlight a letter to view and choose OK.

NOTE: It may take a considerable amount of time to output all the letters to your screen. Often it makes 
more sense to enter a restricted Selection criteria and preview only several letters.

__________________
See also

Create/Edit Mail Merge Letter 
Print Mail Merge 



Create/Edit Mail Merge Letter (Tools Menu)

Mail Merge allows you to choose a group of addresses (or other data) and merge it into a letter. For each 
address selected, a letter is printed. In this way, Mail Merge automates the creation of customized letters.

Create/Edit Mail Merge Letter (Tools Menu)

1. Enter a name for your Mail Merge Report and choose OK.
The askSam Report Layout Editor will appear.

2. Type your Letter. Drag fields from the Field List and place them in the appropriate positions in your 
letter. (Field names can also be typed directly into the Letter).

3. Save your letter by choosing TOOLS -> CLOSE REPORT (or pressing CTRL+S).

NOTE:    Certain formatting options are not supported in the Mail Merge Editor. You cannot set 
Tabs and Page Breaks in Mail Merge Letters. Indents can only be set for the entire Letter and not 
on a line-by-line basis. Graphics are also not available in Mail Merge letters.

Edit Letter

1. Select a previously entered Mail Merge Report and choose OK
The askSam Report Layout Editor will appear including the information from the selected mail 
merge.

2. Make desired corrections.

3. Save your letter by choosing TOOLS -> CLOSE REPORT (or pressing CTRL+S).

________________
See also

View Mail Merge 
Print Mail Merge 



New Report command (Tools menu)

Use this command to create, format, and run a Report.

Dialog Box Options

Report Name
Type or select the name for the report you want to create.    The name can contain multiple words and 
have a length of up to 80 characters.    If you do not specify a name, askSam assigns the name Untitled 
Report # to your Report.

Select the documents to include in your report
Select this Button to build a search request using the Multiple Search Request Dialog Box.    See the 
Multiple Search Request command (Actions menu) for details about the Dialog Box.

Sort the documents to include in your report
Select this Button to Sort the documents in your report. See the Sort command (Actions menu) for details 
about the Sort Dialog Box.

Define the layout for your report
Select this Button to activate askSam's Report Layout Editor.    From the Layout Editor you define the 
format for your Report.    You can insert fields, define which fields will be totaled and grouped, and define 
headers and footers.

Place Field  Selects a field and positions it in the Report Layout.
Show {ewc hmew,ewBitmap,R_SHW_D.BMP} Outputs sentences, lines, or paragraphs containing 
specific word or phrase.

Group Footer  Add text to totals and subtotals from Total and Count commands.

Report Settings  Defines settings specific to the current Report.

Count  Places the number of documents selected or grouped into your report.

Place Text  Places text into your Report.

Header  Defines a header for the Report.

Footer  Defines a footer for the Report.

Reset Row  Sets a Report up in multiple rows.

Close  Closes the Report Layout Editor. Lets you save or cancel your changes.

Run the current Report
Runs the report.

________________
See also
Creating a New Report (Step-by-Step Instruction)



Open/Edit Report command (Tools menu)

Use this command to edit, delete or run an existing report.

Dialog Box Options

Report Name
Type or select the name of the report you want to edit, delete, or run.

Selection
Select this Button the search criteria for the report.    See the Multiple Search Request (Actions menu) for 
details about the Dialog Box.

Sort
Select this Button edit the Sort criteria for the report.    See the Sort command (Actions menu) for details 
about the Dialog Box.

Edit Layout
Select this Button to edit the report layout.    See the New Report command for details.

Run
Runs the report.

Delete
Deletes the selected Report.

________________
See also

Creating a New Report (Step-by-Step Instruction)



Run Report (Tools menu)

Use this command to execute a report.

Shortcut
Toolbar:  

Keys: Ctrl+R

Dialog Box Options

Report Name
Type or select the report you want to execute.



Place Field command (Tools menu)

Use this command to select a field and position it in the Report Layout Editor.

Shortcut

Report Tools:  
Key: F12

Dialog Box Options

Field Name
Type or select the name of the field you want to include in the Report.

Note: The list of field names displayed is generated from the fields listed in the Entry Form of the 
current file.    If no fields are displayed in the list, exit the Report Layout Editor and use the Entry Form
command (Edit menu) to enter the names of the fields in the current file.

Field Type
Defines the text in the specified field as single line or multiple line.    The default setting is single line.

Single Line Outputs the text in a field until either askSam encounters the end of a line or a field 
terminator character ("]").

Multi-line Outputs the text in a field until askSam encounters the designated field terminator 
character.    Enter the field terminator character you want to use.

Format
Defines how the field will be output:
Limit output to Limits the field output to a specified length.

Wrap - Column width Defines a column size for a field.    This prevents the output of one field from 
overwriting the output of the field that follows it.    With the column size set, 
the contents of a field will wrap down to the next line if it exceeds the column 
size.

Retain line breaks Outputs text in your multiple line field exactly as it is stored in your document

Actions
Defines groups, subtotals, and totals for inclusion in the Report.
Group Groups the text from a field.    

Total Totals the designated field.

Spacing
The fields you place using the Field Placement    Dialog Box are output in the column where the first letter 
of the field name is located.    To place a field in a position relative to the preceding field use the Spacing 
option.
Relative Spacing Click the Box to position a field relative to the preceding field in the Report layout.

Type or select the number of spaces you want to precede the designated field.



Options
Defines group and total modifiers for the Report.

Group Modifiers
Match Case Makes the group command case sensitive. When selected, the 

group field is output is upper case letters.

Last Word Groups and outputs on the last word in a field.

Date Specifies that the group field contains a date.

Blank Line between Groups Outputs a blank line between groups.

Page Break between Groups Outputs a page break between groups.

Field Length Defines the number of characters to group and output in your 
report. The default value is 40.

Total Modifiers
Define how the totaled values are formatted.
Numbers w/ Commas Inserts commas in totals and subtotals. Without the total modifier 

activated, one thousand is formatted as 1000.00.    With the total modifier
activated, one thousand is formatted as 1,000.00.

Dollar ($) and commas Inserts the Dollar sign ($) and commas in totals and subtotals. Without 
the total modifier activated, one thousand dollars is formatted as 
1000.00.    With the total modifier activated,one thousand dollars is 
formatted as $1,000.00.

Decimal Place Defines how many decimal places will output after a number.    You can 
choose between 0 and    9.



Group Footer command (Report Tools menu)

Use this command to add text to totals and subtotals in reports. This command is only available in the 
Report Layout Editor.

Shortcut
Report Tools:  

Dialog Box Options

Group Level
Type the group level that you want to have a group footer.    Each grouped field is a group level, the first 
grouped field being the first level.

Footer Text
Type the footer text you want to include.



Report Settings command (Tools menu)

The Report Settings Dialog Box contains important settings that affect the way your Report appears and 
acts. These Report Settings are saved along with your Report and may be changed at any time.

Shortcut
Report Tools:  

Dialog Box Options

Match Case
This Option determines if a search is case sensitive. A case sensitive search is faster. When Match Case 
is selected, please note that the case of the field names in your report must match the case of the field 
names in your Documents.

Output Field Names
When active, this Option outputs the field name along with the field contents. For example:

 With Output Field Names OFF:
                    Author[              would output              Miles Lowther

      With Output Field Names ON:
                    Author[              would output              Author[ Miles Lowther

Output All Occurrences of a field
This Option determines how multiple occurrences of a field within a Document are handled.

· If checked, all occurrences of a field are output.
· If unchecked, only the first occurrence of a field is output.

askSam is very flexible system where defining the structure for your data is concerned. If, for example, 
you have additional telephone numbers you wish to enter into a Document containing only one phone 
field, you can simply add another field.

Name[ Kathy Emery
Phone[ 215-555-0000
Phone[ 215-555-1010

With Output All Occurrences of a Field CHECKED, the request:

Name[                          Phone[ 

Would output:

Kathy Emery 215-555-0000
          215-555-1010

With Output All Occurrences of a Field UNCHECKED, the request would output:

Kathy Emery 215-555-0000



Field Character
This Option defines on a per-report basis what Character designates a field.    Words ending with this 
character are treated like fields. For example, Name[, Company[, To:, or From:.

Set Output Separator
With this Option you can define a Separator that will be output between Documents. This Output 
Separator can be set to:

· A number of blank lines between Documents
· A line of any character separating Documents
· A Page Break between Documents (each Document on a separate page)
· Nothing separating Documents.

When defined from the Report Settings Dialog Box, the Output Separator affects only the current Report. 
You can also access the Output Separator Command from the OPTIONS Menu. Setting the Output 
Separator from the OPTIONS Menu defines the Default setting for your file.

See the Output Separator command (Options menu) for more details about the Output Separator Dialog 
Box.



Count Documents command (Tools menu)

Use this command to count the number of documents selected by a a group command or selected by 
your report.    You must be in the Report Layout Editor to use the Count Documents command.

To count documents when you are not using a report see the    Multiple Search Request and the Count 
Word or Phrase Command.



Place Text command (Tools menu)

askSam allows you to insert text into your reports. These texts can be used as labels to describe parts of 
your report, or they can be longer text passages (sentences, paragraphs, etc.)

Dialog Box Option

Text
Type the text you want to enter into the Report.



Spacing command (Tools menu)

Use this command to define the spacing method when placing fields in the Report. 

Fields are output starting in the column where the first letter of the field name is located. Some reports, 
however, require one field to be positioned relative to the previous field. For example outputting a city field
followed by a comma and then the state. To handle this, askSam allows you to define Relative Spacing. 
Relative Spacing allows you to place fields in a position relative to the preceding field.

Dialog Box Options

Relative Spacing Click the Box to position a field relative to the preceding field in the Report 
layout. Type or select the number of spaces you want to precede the 
designated field.    

Preceded w/ a comma Click the Box if you want a comma to precede the designated field.



Header command (Tools menu)

Use this command to include a Header at the top of every page in a Report (titles, column headings, page
numbers, dates or any other information you want repeated on every page).

Shortcut
Report Tools:  

Dialog Box Options

Header Icons options
 Page Number Inserts the page number. Command ^N.

 Total Pages Inserts the total number of pages. Command ^P.

 Date Inserts the current system date. Command ^D.

 Time Inserts the current time. Command ^T.

 File Name Inserts the name of the current askSam file. Command ^f.

 Path / File Name Inserts the name and path of the current askSam file. Command ^F.

 Left Align Left aligns the header or footer. Command ^L.

 Center Centers the header or footer. Command ^C.

 Right Align Right aligns the header or footer. Command ^R.

Header Text List
Type the text you want in the Header.    Click an icon (described above) to include the code commands 
that automatically stamp information in the Header.    Press Ctrl+Enter to move to the next line in the 
Header text list.

___________________
See also

Using Headers and Footers (Step-by-Step Instruction)



Footer command (Tools menu)

Use this command to include a Footer at the bottom of every page in a Report (titles, column headings, 
page numbers, dates or any other information you want repeated on every page).

Shortcut
Report Tools:  

Dialog Box Options

Footer Icons 

 Page Number Inserts the page number. Command ^N.

 Total Pages Inserts the total number of pages. Command ^P.

 Date Inserts the current system date. Command ^D.

 Time Inserts the current time. Command ^T.

 File Name Inserts the name of the current askSam file. Command ^f.

 Path / File Name Inserts the name and path of the current askSam file. Command ^F.

 Left Align Left aligns the header or footer. Command ^L.

 Center Centers the header or footer. Command ^C.

 Right Align Right aligns the header or footer. Command ^R.

Footer Text List
Type the text you want in the Footer.    Click an icon (described above) to include the code commands that
automatically stamp information in the Footer.    Press Ctrl+Enter to move to the next line in the Footer 
Text List.

___________________
See also

Using Headers and Footers (Step-by-Step Instruction)



Reset Row command (Tools menu)

Use this command to set up a Report in multiple columns.    This command is most commonly used when 
you want to create 2 Wide or 3 Wide Labels.

Shortcut
Report Tool Bar:  

___________________
See also

Creating Mailing Labels (Step-by-Step Instruction)



Tile command (Window menu)

When you simultaneously open several askSam windows, some windows are hidden beneath others.    
Use this command to rearrange all the open askSam windows so that part of each window is visible.



Cascade command (Window menu)

When you simultaneously open several askSam windows, some windows are hidden beneath others.    
Use this command to rearrange all the open askSam windows so that part of each window is visible.



Arrange Icons command (Window menu)

When you minimize an askSam file window, it becomes an icon.    Use this command to arrange the icons
in an order.



Close All command (Window menu)

Use this command to close all open askSam windows.



Contents command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
various reference information and to step-by-step instructions for using askSam.

Once you open Help, you can click the first button on the left in the Help window whenever you want to 
return to the opening screen.
 
See Contents for askSam for Windows Help.



How to use Help command (Help menu)

Use this command to display an introduction to using Help.    From this screen, you can jump to various 
reference information and to step-by-step instructions for using Help.



Search for Help command (Help menu)

Use this command to enter a topic and search for help information relevant to this topic.



Keys Help (Help menu)

Use this command to display a listing and description of the keyboard shortcuts for askSam.

Keyboard Shortcuts

File Keys
Ctrl+N Create New File 
Ctrl+O Open a File 
Ctrl+F4 Close a File 
Ctrl+S Save a File 
Ctrl+P Print 
Alt+F4 Exit askSam 

Edit Keys
Ctrl+Z Undelete 
Ctrl+X Cut 
Ctrl+C Copy 
Ctrl+V Paste 
DEL Delete
Shift+F3 Find 
F3 Repeat Last Find 
Ctrl+D Stamp Date 
Ctrl+T Stamp Time 

View Keys
Alt+PgDn Next Document 
Alt+PgUp Previous Document 
Alt+Home First Document 
Alt+End Last Document 
Ctrl+F2 View Bookmark 
Ctrl+Enter View Hypertext Link 

Actions Keys
Ctrl+Y Hypertext Search 
Ctrl+F Hypertext Search On File 

Document Keys
Ctrl+A Add a Document 
F5 Add a Document with Entry Form 
F11 Pick     List  
Ctrl+Q Tag Document 
F2 Set Bookmark 
F4 Set Hypertext Link 
Ctrl+E Toggle Data Entry Mode 

Format Keys
Ctrl+B Bold 
Ctrl+I Italic 
Ctrl+U Underline 
Ctrl+K Strikeout 
Ctrl+G Repaginate 



Tools Keys
Ctrl+R Run Report 
Ctrl+S Close Report 
F12 Place Field 
F7 Spelling 
Ctrl+W Dial Phone Number 

Help Keys
F1 Help
Shift+F1 Context Sensitive Help 



Help Mode command (Help menu)

Use this command to activate the askSam context sensitive Help mode.      Once activated, clicking on an 
icon or any other part of the askSam screen accesses Help for that item.

Shortcut
Toolbar:  



About askSam command (Help menu)

The About askSam command displays a windows containing the following information:

· Version number
· Who the version is licensed to
· Serial number
· Phone, Fax, and BBS number for askSam Systems
· Size of the current file
· Free Memory
· Free system resources



Add Information (Step-by-Step Instructions)

·      Creating a New File   
·      Creating a New File with an Entry Form   
·      Adding a Document to an askSam File   



Creating a New askSam File (Step-by-step Instruction)

You can create an empty file with no structure, or you can create a file patterned after an existing File 
Template.

Note: askSam comes with standard templates for a variety of tasks -- contact management, writing faxes, 
clippings, a calendar file. New templates will continually be added and existing ones updated. The 
README file contains an up-to-date list of the templates and a brief description of each.

Create an Empty File:
1. Choose FILE -> NEW (or press CTRL+N).
2. The NEW FILE Dialog Box will appear.
3. Enter a name for the file you are creating.
4. Choose OK.

Your screen will clear and you will be in an empty document. You can now either:
· Immediately begin typing the information in the first document;
· Import information into the file;
· Design an Entry Form for the documents you want to enter in this file. 

Create a New File from an Existing Template:
1. Choose FILE -> NEW (or press CTRL+N).
2. The NEW FILE Dialog Box will appear.
3. Enter a name for the file you are creating.
4. Choose the Template that best suits your needs in the USE TEMPLATE field.
5. Choose OK.
6. askSam will create a new file containing the settings from the Template you selected.

Your screen will clear and you will be looking at the first screen of the new document. On the first screen 
will be instructions on how to use this file, its Entry Form, and reports. This document may be deleted at 
any time. Press F5 to add a new document with the existing Entry Form.

___________________
See also

Create a New File with an Entry Form 



Create a New File w/ an Entry Form (Step-by-step Instruction)

You can create an empty file and define a customized structure for the documents you enter in the file 
with an Entry Form.    askSam allows only one Entry Form per file.

Shortcut
Toolbar:   

Create an Empty File:
1. Choose FILE -> NEW (or press CTRL+N).
2. The NEW FILE Dialog Box will appear.
3. Enter a name for the file you are creating.
4. Choose OK.

Your screen will clear and you will be in an empty document. You can now either:
· Immediately begin typing the information in the first document;
· Import information into the file;
· Design an Entry Form for the documents you want to enter in this file. 

To Create an Entry Form
1. Choose EDIT -> ENTRY FORM.

This will activate the Entry Form Editor. The Status Bar will change and an empty Document will 
appear on the screen. This Document is where you will type in the Fields and Text for your Entry 
Form.

All the standard features of the Word Processor are available. You can: change fonts and colors; 
include graphics; insert tabs; modify the margin settings; define headers and footers; and set the 
justification for the text. 

2. Enter the fields, text, and graphics for your Entry Form.
(See the Defining an Entry form for details on how to enter these items.)

4. To save your Entry Form, choose EDIT -> ENTRY FORM (or press CTRL+S).
A message will appear asking if you wish to save your changes. In this message there is an option 
for "Data Entry mode". If you want to enter data in fields, leave this option checked. If you are 
entering information without fields, uncheck this option.

5. Choose YES.

Your Entry Form is saved and you will return to the first document in the file.    To enter a document with 

the Entry Form press F5 (or from the Toolbar    choose  ).

_____________
See Also

Creating a New askSam File 
Defining an Entry Form



Adding a Document (Step-by-step Instruction)

When you add a document to an askSam file, you have to choices:

· You can add structured information by filling out a pre-defined Entry Form.
· You can add a blank document and enter unstructured information.

To Add a Blank Document 

1. Open a file or create a new file.

2. From the Document menu, choose Add (or press Ctrl+A). 
A blank document will appear.

3. Type the information you want in the document.

Shortcut
Toolbar:  

Keys: Ctrl+A

To Add a Document With an Entry Form.

1. Open a file or create a new file.

2.  From the Document menu, choose Add w/Entry Form (F5). 
A new document will appear on the screen overlaid with the Entry Form. 

3. Fill out the Entry Form by typing the information you want in the document.

Shortcut
Toolbar:  

Keys: F5

NOTES:
1. To save a document, choose FILE -> SAVE (Ctrl+S).    From the Toolbar, you can click on the save 

button.

2. To restrict the area on the screen that you can edit and prevent the overwriting of fields, add 
information in Data Entry Mode.

_____________
See Also

Importing Information



Defining an Entry Form (Step-by-step Instruction)

You can create a customized Entry Form to define structure for the documents you enter.    Defining an 
Entry Form also assists you in organizing your information and simplifies data entry.    askSam is a very 
open information management system --    you can vary the degree of structure from file to file or from 
document to document.    Fixed field positions or predefined field lengths are not required.

To define an Entry Form for the file
1. Create a new file or open the file in which you want an Entry Form.

2. Choose EDIT -> ENTRY FORM.
This will activate the Entry Form Editor. The Status Bar will change and an empty Document will 
appear on the screen. This Document is where you will type in the Fields and Text for your Entry 
Form.

All the standard features of the Word Processor are available. You can: change fonts and colors; 
include graphics; insert tabs; modify the margin settings; define headers and footers; and set the 
justification for the text. 

3. Enter the fields, text, and graphics for your Entry Form.
(See the sections immediately following for details on how to enter these items.)

4. To save your Entry Form, choose EDIT -> ENTRY FORM (or press CTRL+S).
A message will appear asking if you wish to save your changes. In this message there is an option 
for "Data Entry mode". If you want to enter data in fields, leave this option checked. If you are 
entering information without fields, uncheck this option.

5. Choose YES.

Your Entry Form is saved and you will return to the first document in the file.    To enter a document with 
the Entry Form, press F5.

Inserting Text And Graphics In An Entry Form

Entering text and graphics in the Entry Form works exactly the same as entering text and graphics in the 
normal askSam word processing mode.    Type in your text and select any formatting commands (fonts, 
colors, alignment, margins) and define any headers and footers. You can also use the Cut, Copy and 
Paste functions to transfer texts or graphics into the Entry Form. 

To include graphics in an Entry Form, you can either paste in the graphic or use askSam's OLE functions 
to embed or link the graphic. 

When a Bitmap graphic is copied into an askSam Entry Form, the graphic will only be stored once in the 
askSam file - and not in each Document entered with the Entry Form. This saves space in your file.

Inserting Fields in an Entry Form

To structure information askSam allows the use of fields. Entering fields into an Entry Form is as simple 
as typing text. No special definitions are required. Just type the field name in the row and column where 
you want it to appear. For example:



    Title[
    Author[
    Publisher[

If you want more than one field on a line, insert a closing bracket (    ] ) where the first field should end, 
and then type in the next field name. For example:

    Name[
    Age[              ]    Sex[                  ]        Race[                            
]

The closing bracket ends the field and also can be used to restrict the field length. When a field is output 
in a Report, it is output until the end of a line or until a closing bracket ( ] ).
There is no limit to the number of fields that you can insert in an Entry Form. The length of a field can be 
up to 16,000 lines.

NOTES:
1. If you are planning to use Data Entry Mode to enter your data, do not use tabs between the field 

name and the end of the field (closing bracket). Doing so will prevent you from properly entering your
information. In the following example:
Name[                                            ]          Phone[                                           
]
the space between Name[ and the closing bracket ( ] ) and Phone[ and the closing bracket must be 
filled with spaces.

2. Do not insert spaces between the field name and the opening bracket ( [ ). For example: 
                            Name                [

would not work as a field name.

3. A field name cannot contain spaces. If you want a multiple word field name, connect the words with 
the underline character. For example: Call_Back[

4. Your field names may be as long or as short as you wish. One approach is to have as few 
distractions as possible on the screen. Here keeping the field names as short as possible is the 
priority. For example:

T[ 
A[
P[
Y[

In other cases, especially when other users are entering information, it is essential that the form be 
as self-explanatory as possible. In this case, you would use longer field names to better indicate 
what information they contain. For example:

Title[
Author[
Publisher[                                                              ]    Year[                  ]

5. Aligning Fields on the right bracket often makes your Entry Form more appealing. For example:
Title[
Author[
Publisher[



Year[
Align fields by inserting spaces before the field name. Do not insert spaces between the field name 
and the opening bracket ( [ ).

6. Your fields may be entered in any font. If you choose a proportional font and have multiple fields on a
single line, you will notice that the position of the second field in the line moves as your information is
entered. This will not occur if you use a nonproportional font (such as Courier or Courier New).

7. You can enter fields in a different color from the text. You can also make the closing brackets 
invisible by turning them white if you find them distracting.



Export Information (Step-by-step Instruction)

Use askSam's Export features when you want to transfer information from askSam to other applications. 
askSam lets you export information in a variety of formats. Unstructured information can be exported as 
text, RTF, HTML, or word processing files.    Structured information can be exported for use with other 
databases, spreadsheets, or for mail merge with word processors (using the CSV, Tab Delimited, or Fixed
Position formats).

To Export from askSam

1. Open the file containing the information you want to export.

2. Choose FILE -> EXPORT.
A Menu will appear containing six options.

· Current Document - Exports the Document displayed on the screen.
· Entire File - Exports all Documents in the current file.
· Tagged Document - Exports the Tagged Document (only available if a Document is tagged in 

the current file.)
· Select Documents - Allows you to Export a Selected group of Documents.    This option 

accesses the Multiple Search Dialog Box. Enter a Selection and only the selected Documents 
are exported.

· Selection - Exports the selected (or highlighted) text in the current Document.
· Report - Exports the output of a Report. Selecting this Option will display the RUN REPORT 

Dialog Box. Select the Report you wish to Export and choose OK.

3. Choose one of the Options listed above.
The EXPORT Dialog Box will appear.

4. Enter a name for the file you are Exporting. 

5. Choose the File Type Option and select the appropriate file type.

6. Choose OK.
A Message Box will appear showing how many Documents have been exported.

7. Choose CLOSE when the Export is complete.

_______________
See also

Export command (File menu)



Using Graphics and OLE (Step-by-step Instruction)

While askSam cannot create Graphics, it does allow you to insert graphics into your askSam documents.  
There are three methods for inserting Graphics:

· Inserting graphics with the Insert Picture command.
· Pasting graphics from the Clipboard.
· Using OLE (Object Linking and Embedding).

Inserting Graphics
The EDIT -> INSERT PICTURE command inserts a graphic in an askSam Document or Entry Form. The 
INSERT PICTURE command imports graphics from a variety of formats.

1. Place the cursor where you want to insert the graphic.

2. Choose EDIT -> INSERT PICTURE.
The Insert Picture dialog box will appear. 

 
3. Select the graphic file you want to insert and choose OK.

The graphic is inserted in your document. 

Pasting a Graphic Using the Clipboard
You can paste graphics from the Clipboard into Documents and Entry Forms.

1. Go to the application containing the graphic you want to copy into askSam.

2. Select the graphic.

3. Choose EDIT -> COPY in the application.

4. Go to askSam.

NOTE: Provided you have enough memory, Windows allows you to have multiple applications open 
in separate windows. You can then switch through your open applications by pressing ALT+TAB.

5. Position the cursor in your askSam Document or Entry Form where you want the graphic inserted.

6. Choose EDIT -> PASTE (or press CTRL+V).
The graphic will be inserted at the cursor position.

 

To Deleting a Graphic
1. Go to the document containing the Graphic you want to delete.

2. Use the cursor keys or the mouse to Select the graphic.    See Selecting Text (Word Processing).

3. Press the DELETE key. The Graphic is deleted.

OLE (Object Linking and Embedding)



OLE (Object Linking and Embedding) allows you to insert objects from other applications into your 
information.    Graphics, sounds, video clips, or worksheets can be inserted into your information and yet 
still retain their connection to the application in which they were created.

What is OLE?
OLE is made up of two components:    Object Linking and Object Embedding.    Both allow you to insert 
objects into an askSam document, but they do it in different ways.

When you Link an object, the object is stored in the application where it was created. askSam creates a 
link to this object within your document.    Any change made to the object in the source file is reflected in 
the object in askSam.

When an object is Embedded, the object is actually stored in your askSam document.    To edit this object,
you can Double Click on it in askSam and start the application in which it was created.

Various applications handle OLE in different ways.    Some applications act as "OLE Servers", providing 
objects to other applications.    Other applications act as "OLE Clients", storing the objects from the 
Servers.    askSam acts as an OLE Client.

To Insert a Linked Object
1. Start the Server Application and create or open the Object you wish to insert into askSam.

2. Select the object in the Server Application.

3. From the Edit menu in the Server Application, choose Copy. The Selected object is copied to the 
Clipboard.

4. Switch from the Server Application to askSam.

5. Open the file containing the document or Entry Form into which you want to insert the Graphic.    See
the Open command (File menu).

6. Make the document into which you want to insert the Graphic the current document.    See 
Searching.

7. From the Edit menu, choose Paste Link. The object is inserted, and a link is created between the 
object and the Server Application.

To Edit a Linked Object
1. Open the file containing the graphic to edit. See the Open command (File menu).

2. Make the document, containing the Graphic to edit, the current document.    See Searching.

3. Select the object you want to edit.    See Selecting Text (Using the Word Processor).

4. From the Edit menu, choose Edit xxxx Object ("xxxx" represents the name of the Server Application 
linked to this object). With a mouse, you can Double Click on the object. The Server Application is 
started.

5. Edit the object using the features of the Server Application.

6. From the File menu of the Server Application, choose Save.



7. From the File menu of the Server Application, choose Exit. The askSam document is displayed with 
the object edited.

 To Break a Link
1. Open the file containing the graphic to edit. See the Open command (File menu).
2. Make the document, containing the graphic to edit, the current document.    See Searching.
3. From the Edit menu, choose Links.    See the Links command (Edit menu). The Links Dialog Box 

appears.
4. Type or select the Link you want to break.
5. Choose the Cancel Link Button.
6. Choose OK. The object remains in the document, but the link to the Server Application is canceled.

To Delete a Object and a Link
1. Go to the document containing the linked object you want to delete.
2. Use the cursor keys or the mouse to Select the object.    See Selecting Text (Word Processing).
3. From the Edit menu, choose Delete (Del). The object and the link are deleted.

To Embed an Object
1. Start the Server Application and create or open the Object you wish to insert into askSam.
2. Select the object in the Server Application.
3. From the Edit menu in the Server Application, choose Copy. The Selected object is copied to the 

Clipboard.
4. Switch from the Server Application to askSam.
5. Open the file containing the document or Entry Form into which you want to insert the Graphic.    See

the Open command (File menu).
6. Make the document into which you want to insert the Graphic the current document.    See 

Searching.
7. Position the cursor at the position you want the object embedded in the document.
8. From the Edit menu, choose Paste Special.    See the Paste Special command (Edit menu). The 

Paste Special Dialog Box appears.
9. Choose the Paste Button. The object is embedded in the document at the cursor position.

To Edit an Embedded Object
1. Open the file containing the embedded object you wish to edit. See the Open command (File menu).
2. Make the document, containing the embedded object to edit, the current document. See Searching.
3. Select the object you want to edit.    See Selecting Text (Using the Word Processor).
4. From the Edit menu, choose Edit xxxx Object ("xxxx" represents the name of the Server Application 

linked to this object). With a mouse, you can Double Click on the object. The Server Application is 
started.

5. Edit the object using the features of the Server Application.
6. From the File menu of the Server Application, choose File Update.
7. From the File menu of the Server Application, choose Exit. The askSam document is displayed with 

the object edited.



Importing Information (Step-by-step Instruction)

You can import information in a variety of formats.    Unstructured information can be imported as text, 
HTML, word processing, or RTF files.    Structured information can be imported from other databases or 
from word processors.

To import into askSam

1. Open a file (or create a new file).

2. Choose FILE -> IMPORT.
The IMPORT Dialog Box will appear.

3. Define the format of the information you are Importing by selecting the File Type option.

4. Type in the name of the file you wish to Import (or select it from the list of file names).

5. Choose OK.
A Message Box will appear showing the status of your Import.

5. When your Import is complete, choose CLOSE.

askSam can import from a variety of file formats. See thee Import command for a list of the supported 
formats, as well as a description of the other import options.



Create Mailing Labels (Step-by-step Instruction)

You can use the askSam Report Writer to design Mailing Labels which meet a variety of specifications.

To Print Continuous Labels

1. Open the file containing your addresses.

2. Choose TOOLS -> NEW REPORT.
The New Report Menu will appear.

3. Enter a name for your Labels Report. For example: Mailing Labels

4. Choose the Select button, enter a search request for the desired addresses, and choose OK. (See 
the Multiple Search Request for instructions on the Multiple Search Dialog Box.)

5. Choose the Sort button, enter your sort request, and choose OK.

6. Choose the Layout Design button.
The Report Layout Editor will appear.

7. Drag the fields for your labels from the Field List into the Report Layout:

Name[
Company[
Address1[
Address2[
City[ ,    State[ ^2 Zip[

8. Choose TOOLS -> REPORT SETTINGS and select the Set Output Separator button.

9. In the Document Separator Dialog Box select the option Page Break between Docs and choose 
OK.

10. Choose OK to return to the Report Layout Editor.

11. Choose TOOLS -> CLOSE REPORT and select Yes to save your report.

12. Before printing your labels, choose FILE -> PAGE SETUP, select the File Settings option, and set 
the margins to zero. 

13. You will now need to set the Paper Size. To do this start the Control Panel from the Windows 
Program Manager and select PRINTERS. Choose the Setup Button in the Printers Dialog.

14. Set the Paper Size to User Defined.
The User Defined Size Dialog will appear. 

15. Enter the width and length of your label and choose OK.

NOTE: The Length you set for your label should be the label size plus the size of the space 
between labels. For example, a 4" x 1 7/16" label would require a length of 2".

16. To print your labels return to    askSam and choose FILE -> PRINT. Select the Report option and 



choose the appropriate Report name.

Printing 3 Wide Labels

For Labels as well as other types of Reports, it is possible to have askSam output multiple columns. The 
Reset Row Command allows you to create multiple column Reports.

To illustrate how this is done, we'll look at an example:

1. Follow steps 1 through 6 in the previous example. Make sure you define a sort command. The 
Reset Row command requires sorted output.

2. In the Report Layout Editor set the right margin to 8.5" (wider if necessary).

3. Place the fields for your labels (starting at column 1 row 1):

Name[
Company[
Address1[
City[ ,    State[ ^2 Zip[

NOTE: In order for your labels to line up correctly, output your addresses in the COURIER font (not 
Courier New).

4. After placing your fields, choose TOOLS -> RESET ROW.

5. With a Mouse: Position the mouse pointer after the last field (Zip[ in the example above) and click 
the left mouse button.

With the Keyboard: Use the cursor keys, SPACE BAR, and ENTER key to position the cursor after 
the last field (Zip[ in the example above) Press CTRL+ENTER to insert the Reset Row Command.

A ^R will be inserted in your report.

6. In the line under the ^R, place the fields for your second column of labels. Place the fields in the 
proper column (for standard 3 Wide Labels on a laser printer, place your fields in column 36 (2.88").

    Name[
    Company[
    Address[
    City[, State[ ^2 Zip[ ^R
                                                                      Name[
                                                                      Company[
                                                                      Address[
                                                                      City[, State[ ^2 
Zip[ 

7. Repeat steps 3 - 5 for 3 Wide Labels.    For standard 3 Wide Labels place your fields in column 71 
(5.81").

8. Choose TOOLS -> REPORT TOOLS -> REPORT SETTINGS and select the Set Output Separator 
button.

9. In the Document Separator Dialog Box set the Output Separator to 3 lines between Documents. 
(The number of lines you set is determined by the number of lines in your address. For standard 3 



Wide Labels on a laser printer, the number of lines in the address plus the number of lines skipped 
must equal 7).

10. Return to the Report Layout Editor, choose TOOLS -> CLOSE REPORT, and select the Yes button 
to save your report.

11. Before printing your labels, choose FILE -> PAGE SETUP, select the File Settings option, and set 
the left, right, top, and bottom margins to 0. 

NOTE: Because most printers reserve margin space, setting your margins to 0 will result in minimal
margin settings of 0.125".

12. To print your labels choose FILE -> PRINT, select the Report option and choose the 
appropriate report name.

_______________
See also

The REPORTS.ASK file and the Address Template supplied with askSam contain example reports for
generating mailing labels.

The file LABELS.ASK contains the sizes and settings necessary to print various size labels. This file 
is available on our BBS, CompuServe Forum, and Internet FTP Site.

If you have any questions or experience difficulties, please contact our Tech Support department. 
We'll be happy to assist you - 904-584-6590.



Creating Mail Merge Letters (Step-by-step Instruction)

Mail Merge allows you to choose a group of addresses (or other data) and merge it into a letter. For each 
address selected, a letter is printed. In this way, Mail Merge automates the creation of customized letters.

To Create a Mail Merge Letter

1. Open the file containing the addresses you want to merge.

2. Choose TOOLS -> CREATE/EDIT MAIL MERGE LETTER.
The Create/Edit Mail Merge Letter Dialog Box will appear.

3. Enter a name for your Mail Merge Report and choose OK.
The askSam Report Layout Editor will appear.

4, Type your Letter. Drag fields from the Field List and place them in the appropriate positions in your 
letter. (Field names can also be typed directly into the Letter).

Following is an Example:

Name[
Company[
Address[
City[ ^0, ^1 State[ ^2 Zip[

Dear Salutation[ ^0,

We would like to remind you that your account with us is past 
due.    Please transfer payment of Amount[    ^2 immediately.

Thank you.

Miles Lowther

NOTE:    You can also use the Windows' Clipboard to paste in a letter from another askSam file or 
another application.

5. After completing your Letter, choose TOOLS à CLOSE REPORT (or press CTRL+S) and choose 
YES to save your Letter.

6. Now that you have completed your Letter and saved it, you can either view or print your merged 
letters. 

NOTE:    Certain formatting options are not supported in the Mail Merge Editor. You cannot set 
Tabs and Page Breaks in Mail Merge Letters. Indents can only be set for the entire Letter and not 
on a line-by-line basis. Graphics are also not available in Mail Merge letters.

To View A Mail Merge Letter

1. Choose TOOLS -> VIEW MAIL MERGE and select the name of the letter you wish to preview.



2. If you only want to send letters to a selected group of addresses, choose the Selection button. The 
Multiple Search dialog will appear. Enter a Search request to select the addresses for this letter and 
choose OK.

3. If you want the letters in a particular order, choose the Sort button to define a sort order and choose 
OK.

4. Choose OK to view the letters.

NOTE: It may take a considerable amount of time to output all the letters to your screen. Often, it 
makes more sense to enter a restricted Selection criteria and preview only several letters.

To Print A Mail Merge Letter
Once you have created a Mail Merge Letter, you can print it. To Print a Mail Merge Letter:

1. Open the file containing your Mail Merge Letter.

2. Choose TOOLS -> PRINT MAIL MERGE.
The Print Mail Merge Dialog Box will appear.

3. Choose the name of the Letter you wish to print.

4. If you only want to send letters to a selected group of addresses, choose the Selection button. The 
Multiple Search dialog will appear. Enter a Search request to select the addresses for this letter and 
choose OK.

5. If you want the letters in a particular order, choose the Sort button to define a sort order and choose 
OK.

6. Choose OK to print the letters.



Creating HTML Documents (Step-by-step Instruction)

HTML (Hypertext Markup Language) is the format used in documents on the Internet (World Wide Web). 
Home pages, product brochures, a variety of publications, and other information are available in HTML 
format. askSam gives you the ability to create documents and export them in HTML format. You can also 
take HTML documents from the Internet and import them into an askSam database.

Creating HTML Documents in askSam

Documents you create in askSam can be exported in HTML format. askSam's Word Processor gives you 
the ability to use simple HTML formats without having to learn the HTML command language. You create 
an HTML document just as you create a normal askSam document. The difference lies in the commands 
you use to format the document. After your document is formatted, you export it from askSam in HTML 
format. You can then place it on the Internet. 

There are certain formatting options in askSam which correspond to HTML formats. These formats can be
found in the FORMAT -> HTML menu.

The HTML formats supported in askSam are:

• Normal Text
• Main Title
• Heading 1 through 6
• Un-numbered Lists
• Numbered Lists
• Definitions Lists
• Blockquote
• Preformatted Text
• Emphasis
• Horizontal Line

Examples of these formats follow.

Normal Text - Use this format for the standard text in your HTML documents. In askSam Normal Text is 
displayed in the 12 point Times Roman font.    Example:

ABC Corp. is one of fastest growing companies in the United States. 
Outstanding products and outstanding customer service have become 
trademarks of ABC....

Main Title - The Main Title defines the Title Text for the HTML Document you create. The Title is 
displayed in the Title Bar of your Browser (not in the Text of the HTML Document). In askSam the Main 
Title is displayed in 10 Point System Italic, and it is centered. The Main Title must be in the first line of 
your askSam Document. Example:

                                                                  ABC Corporation Home Page

                    Welcome to ABC Corp's Home Page



ABC Corp. is one of fastest growing companies in the United States. 
Outstanding products and outstanding customer service have become 
trademarks of ABC....

Heading 1 through 6 - use for various size headings in your HTML Documents.

Heading 1 - Times Roman Bold 24
Heading 2 - Times Roman Bold 20
Heading 3 - Times Roman Bold 18
Heading 4 - Times Roman Bold 14
Heading 5 - Times Roman Bold 10
Heading 6 - Times Roman Bold 8

Un-numbered List - use for bullet lists. Un-numbered lists are displayed in 12 point Times Roman, 
indented, with bullets. To end an un-numbered list, you must insert a blank line without any tab stops. 
Example:

    Breaking News
    August 25, 1995 4:00 p.m. ET

    · Hayes and Boca: Playing the waiting game
    · Compaq enlists Ingram for help with PC mail order
    · Microsoft celebrates Win 95 day as DOJ continues probe
    · Boca Research bails on Hayes merger; execs swap charges

Numbered List - use for numbered lists. Numbered lists are displayed in 12 point Times Roman, 
indented, and numbered. To end a numbered list, you must insert a blank line without any tab stops. 
Example:

    Rugby World Cup - Match reports
    1.      25 May : South Africa v. Australia (27-18)
    2.      26 May :Scotland v. Cote D'Ivoire (89-0)
    3.      26 May : France v. Tonga (38-10)
    4.      26 May :Canada v. Romania (34-3)

Definition List - use for lists of definitions. Definition lists are in 12 point Times Roman and have the 
format shown in the following example:

The askSam Product Line
ASKSAM FOR WINDOWS
                          an easy-to-use, free-form database for organizing information



ASKSAM FOR WINDOWS NETWORK VERSION
                        use askSam to share information in workgroups. Runs on any
                      Windows-compatible network. Supports record locking.

Blockquote -    use to indent text passages, for example quotations. Example:

    In the words of Mark Twain:
 "When I was a boy of fourteen, my father was so ignorant I could 
hardly stand to have the old man around.    But when I got to twenty-one,
I was astonished at how much he had learned in seven years."

Preformatted Text -    use for texts that should not be reformatted, such as tables. Example:

 The following is a summary of your portfolio:

 Company  Invested      Current            P/L
 AT&T                                          5914.85        5200.00        -714.85

 Chrysler                                  8170.39        8825.00          654.61  

 China Industries                  4039.63        3876.00        -163.63 
 Diag. Retrieval Sys.          3512.60        6062.00        2549.40 

Emphasis - use to emphasize a word or passage. Text is displayed as bold and italic. 

Horizontal Rule - places a line across the screen. Use to separate sections of a text in your Documents.

Inserting HTML Formats in a Document:

1. Write your text. Do not use tabs, fonts, colors, and margins.

2. Select the text you want to format.

3. Choose FORMAT -> HTML
The HTML format commands will appear.

4. Select the format you require.
Your text will be reformatted according to the format you chose.

NOTES:

1. When creating an HTML document, only use fonts inserted by the HTML commands in the Format 
Menu. Do not insert other fonts.

2. Certain formats cannot be exported to HTML Documents: tabs, colors, and margins.

3. If you insert multiple spaces at the beginning of a line, the text following those spaces will be 
displayed as a preformatted text (in Courier). 



4. There are more advanced HTML formats that are not supported in askSam. To use any HTML 
features not implemented in askSam, use an HTML editor and edit the HTML documents you export 
from askSam.

Inserting Graphics in a HTML Document

You can insert graphics in your HTML documents just as you would insert them in your regular askSam 
documents. Either paste graphics from the clipboard or insert graphics with the EDIT -> INSERT 
PICTURE command. Place the graphics where you want them to appear in your HTML document. If you 
paste a graphic from the Clipboard, use the EDIT -> PASTE SPECIAL command and paste the graphic as
a Bitmap (not an OLE object). OLE Objects are not exported in HTML documents.

After you've finished designing your document, export it from askSam in HTML format. The graphics are 
also exported and given randomly generated file names. You can view your HTML Document with 
graphics using any HTML browser.

Inserting Hypertext Links in an HTML Document

askSam's Hypertext function lets you include Hypertext Links in your askSam files. When you export this 
information in HTML format, askSam can transfer these Hypertext Links. You insert Hypertext Links in 
your HTML documents just as you would insert them in your regular askSam documents.

askSam offers several types of Hypertext Links. The type of link you define in askSam will determine how 
it will be exported in the HTML file:

Hypertext Link to:  Will export as:
Current Document  Link in the current HTML file
Current File  Link in the current HTML file
Other File  Link to another HTML file (same site)
Reports in Current File  Not Supported
Reports in Other File  Not Supported
Menu Commands  Not Supported
External Applications  Not Supported
HTML URL  Link to URL which you enter

Setting a Hypertext Link in the Current File

1. Select the text you want to link.

2. Choose DOCUMENT -> SET HYPERTEXT LINK (or press F4)
The Set Hypertext Dialog Box will appear.

3. Choose a Link To Current Document or Current File.
A List of Bookmarks in the current Document or File will appear.

4. Select the desired Bookmark and choose OK.
The Hypertext Link is set.

In askSam:
Clicking on the Hypertext Link you will jump to another position in the current askSam file.

In the HTML document you export:
Clicking on the Hypertext Link you will jump to another position in the current HTML document.



Setting a Hypertext Link to Another File

1. Select the text you want to link.

2. Choose DOCUMENT -> SET HYPERTEXT LINK (or press F4)
The Set Hypertext Dialog Box will appear.

3. Choose a "Link To Other File".

4. Choose the Browse button and select the file you want.
A list of Bookmarks in the selected file will appear.

5. Select the desired Bookmark and choose OK.
The Hypertext Link is set.

In askSam:
Clicking on the Hypertext Link you will jump to the bookmark in the other askSam file.

In the HTML document you export:
Clicking on the Hypertext Link you will jump to the bookmark (anchor) in another HTML document.

How Links to Another File are Exported
When you set a Hypertext Link from one askSam file to another askSam file, the Link records the drive, 
path, and name of the file you link to. When you click on the Hypertext Link, askSam opens the other file 
and jumps to the appropriate position.

When a Hypertext Link to another file is exported in an HTML document, askSam must change the link to 
go from one HTML document to another HTML document (you cannot have an HTML link from an HTML 
document to an askSam file). To properly maintain the link, askSam must convert the drive, path, and file 
name to a valid URL (internet address). In order to do this, we require you to define a URL for the server 
where you will be placing the files.

You define this setting in the OPTIONS -> GLOBAL PREFERENCES menu. Choose the HTML button, 
and enter the URL for your server. For example: http://www.asksam.com

When you export a Hypertext Link to another file, askSam will replace the drive and path name with the 
URL for your server and replace the file extension with HTM.

For example, if you define a link in your askSam file to the Main Menu Bookmark in the askSam 
file BROCHURE.ASK and then export this to HTML, the following would happen:

Original Link: C:\AS_WIN\BROCHURE.ASK - Main Menu Bookmark.
HTML Link: http://www.asksam.com/BROCHURE.HTM#Main Menu

In order for the link in the HTML document to work properly, you would need to export the 
BROCHURE.ASK file as an HTML document and place it on the server as the file BROCHURE.HTM in 
the appropriate directory.

Setting a Hypertext Link to Another Internet Site or any URL

Defining a Hypertext Link to a URL lets you create HTML documents which contain links to other sites on 
the Internet.



To Create a Hypertext Link to a URL:

1. Select the text you want to link.

2. Choose DOCUMENT -> SET HYPERTEXT LINK (or press F4).
The Set Hypertext Dialog Box will appear.

3. Choose a Link To an HTML URL.

An edit box will appear where you can enter your URL. For example:
http://www.askSam.com/askSam.htm

4. Choose OK after you enter the URL.
The Hypertext Link is set.

In askSam:
Clicking on the Hypertext Link askSam will display a dialog box containing the URL address. From this 
dialog box you can copy the URL to the clipboard. This makes it easy to switch to your browser and paste
the URL in the Location field. 

In the HTML document you export:
Clicking on the Hypertext Link, you will jump to the site or HTML file at the address you specified.

Exporting HTML Documents from askSam
        
When you create a Document in askSam, it is not an HTML Document until you export it in    HTML 
format. This is when askSam transfers the text and formatting information into HTML format. Exporting a 
Document in HTML format is a straightforward task.

To Export a Document in HTML Format:

1. Go to the Document you wish to export.

2. Choose FILE -> EXPORT -> CURRENT DOCUMENT
The Export Dialog box will appear.

3. Enter a name for the HTML file you will export (normally with an *.HTM extension)

4. Select HTML as the File Type for your export.

5. Choose OK.
You document will be exported in HTML format.

______________
See Also

Export
Hypertext
Inserting Graphics
HTML Options



Importing HTML Documents (Step-by-Step Instruction)

Much of the information you gather on the Internet will be in HTML format. A flood of information is now 
available on the World Wide Web, and askSam is the perfect way to turn this downloaded information into
your personal database.

Importing a downloaded HTML file:

1. In your Web Browser (for example Netscape), choose FILE -> SAVE and enter a name for the Web 
Page you wish to save. You can save multiple Documents and later import all of these Documents 
into askSam.

2. After saving the HTML Documents, go to askSam and create a new file or open an existing file. 

3. Choose FILE -> IMPORT
The Import Dialog box will appear.

4. Select HTML as the File Type.

5. Choose the HTML file or files you want to import and choose OK.

The HTML document will be imported into the current askSam file.

NOTES:
1. When you save an HTML document from a browser (such as Netscape), the text and formats from 

the HTML document are saved. The graphics are not downloaded to your system. To simplify getting
graphics, askSam automatically checks your Netscape browser directory. If Netscape has the 
graphical information, askSam will include the graphics in the imported documents.

You define your Netscape directory in the OPTIONS -> GLOBAL PREFERENCES menu. Choose 
the HTML button and enter the directory.

If you are not using Netscape, you can still import graphics with your HTML Documents. You will 
have to download the graphics and place them into the same directory as the HTML file you want to 
import.

2. Although askSam does compress graphics, images require much more space than text. If you do not
want to import graphics, turn off the Import Graphics option in the OPTIONS -> GLOBAL 
PREFERENCES -> HTML dialog box.

3. When you import an HTML file, each graphic you import will only contain a single Hypertext Link.

4. askSam retains the Hypertext Links in HTML Documents you import. If the link is in the current 
Document, clicking on the link will move you to the appropriate place in your Document. If the link is 
to another Document or Internet Site, askSam will display a message box with the Address from the 
link.

______________
See Also

Import
HTML Options



Reports (Step-by-step Instruction)

·      Creating a New Report   
·      Editing an Existing Report   
·      Printing a Report   
· Running a Report



Creating a New Report (Reports Step-by-step Instruction)

You can use the askSam Report Writer to view information from multiple documents in a file in an 
organized and summarized manner.    The Report Writer also allows you to store frequently used 
searches and requests.

Before you create a report, you need to know the purpose of the report.    Are you saving a search 
request?    Creating a sorted list?    Totaling and tallying data?

The Purpose of the Report determines:
·What documents you select to include in your Report.
·How these documents are sorted.
·What fields are included in the Report.
·How the Report is formatted.

Once you know this information, creating, editing, and running a report is simple.

To Create a New Report

Reports are created with the New Report command (Tools Menu).    This New Report Dialog Box allows 
you to execute the steps necessary to create a report:

· Selecting documents to include in the Report
· Sorting the documents
· Defining a layout for the Report.

A Report does not require all three of these elements.    In fact, a Report may consist of any one element, 
any combination of elements, or all three elements combined.

1. Choose TOOLS -> NEW REPORT.
The New Report Menu will appear.

2. Enter a name for your Report in the Report Name field. 

3. Choose the Select Documents Button.

  

NOTE: To choose this Button with the keyboard, move to the Select Documents Button by using the
TAB key or by pressing ALT+S. Then press the SPACE BAR.

The Multiple Search Dialog Box will appear. 

4. Enter your search request and choose OK.
You return to the New Report Menu.

5. Choose the Sort Button.



The Sort Dialog Box will appear. 

6. Enter your Sort Command and choose OK
You will return to the New Report Menu.

7. Choose the Define Layout Button.

You will enter askSam's Report Layout Editor. From this Editor you can define the layout for your 
Report. You can insert fields, define which fields will be totaled and grouped, as well as define 
headers and footers. The complete features will be described later in this chapter. This example will
show you how to place a field.

8. Select the field you want to place in your report from the Field List in the lower right hand corner. 
Drag the field name to the position where you want it in your report and Drop it. 

9. Repeat step 8 until you have placed all the fields you want in your Report. 

10. Choose TOOLS -> CLOSE REPORT (or press CTRL+S) to close the Report Layout Editor. A 
message will appear asking if you wish to save your Report. Choose Yes.

You will return to the New Report Menu.

11. To run your Report choose the RUN Button.

NOTES:
1. There are various formats and report settings that affect the appearance of your Report. (See New 

Report and Report Tools.)

2. When a Report outputs information from multiple Documents, you can define a separator to be 
inserted between the information from those Documents. (See Output Separator.)



Editing an Existing Report (Step-by-step Instruction)

Once you create a report, you can edit, run, or delete if from the Report Manager.

To Edit a Report

1. Open the file containing your report.

2. Choose TOOLS -> OPEN/EDIT REPORT.
The Report Manager Dialog Box will appear.

The Buttons in the Report Manager have the following functions:
Selection Opens the Multiple Search Dialog Box. If the selected Report contains a Search 

Request, this will be shown in the Search List. Use the Multiple Search Dialog to edit
the Search Request.

Sort Opens the Sort Dialog Box. If the selected Report contains a sort request, you can 
edit it using this Dialog Box.

Edit Layout Opens the Report Layout Editor. From the Editor, you can add, delete, reposition, or 
format fields.

Run Runs the selected report.
Delete Deletes the selected report.

To Delete a Report

1. Open the file containing your report.

2. Choose TOOLS -> OPEN/EDIT REPORT.
The Report Manager Dialog Box will appear.

3. Type or select the name of the Report you want to delete in the Report Name Box.

4. Select the Delete Button. 
A message appears asking you to confirm your decision.

5. Choose Yes. 
The Report is deleted.



Printing a Report (Reports Step-by-step Instruction)

There are two ways to print a Report.    You can print it directly, or you can run a Report and then print 
from the report output.

To Send a Report Directly to the Printer

1. Open the file containing the Report you wish to print.

2. Choose FILE -> PRINT (or press CTRL+P).

3. Choose the Report Option.
A list containing the names of the Reports in the current file will appear. 

4. Select the name of the Report you want to print.

5. Choose OK.
A Dialog Box will appear and your report will be printed.

To Send Report Output to the Printer
Any report in which a Layout is defined will create a new Window when it is run. The contents of this 
Window can be Formatted, Edited, and Printed.

1. From the Report Output, Choose FILE -> PRINT (or press CTRL+P).
The Print Dialog Box will appear. 

2. Choose OK.

Prevent Documents from Splitting 
When you print a report containing information from multiple documents, askSam keeps Documents from 
splitting across pages (if the Document is smaller than a page). If you don't care where your page breaks 
occur, you can save paper by turning this option off.    The "Keep documents together when printing 
reports" option can be set globally in the OPTIONS -> GLOBAL PREFERENCES dialog box.

Printing Each Document on A Separate Page
When a Report outputs information from multiple Documents, you can use the Output Separator to insert 
a page break between the information from each Document.



Running a Report (Step-by-step Instruction)

Once you have defined a Report, you can easily run it at any time.

To Run a Report

1. Open the file containing the Report you want to run.

2. Choose TOOLS -> RUN REPORT (or select the RUN Button).
The Run Report Dialog Box will appear.

3. Choose the name of the Report you want to run.

4. Choose OK.

The report you selected is run and one of three things will happen:

1. If you defined a layout for the Report —

A new window will open and the Report will be output in this window. If you double click on any line 
in the Report, you return to the Document containing the information in that line. By pressing 
CTRL+TAB you can move between your file and the Report. You can also , Edit, and Save the 
contents of the Report.

2. If you created a Report with a Search or Sort request but without a layout —

The first Selected Document will be displayed and the Retrieval Dialog Box will appear. You can 
move through your information by choosing Next, Previous, or Cancel. 

3. If askSam does not find any Documents that meet your search criteria —

A Message Box will appear informing you that no matches were found. If this happens, check your 
selection criteria.

NOTE: 
If a Report opens a second window, you can return to your original File by:

· Double clicking on any line in the Report (you return to the Document containing the information 
you clicked on).

· Closing the window containing the Report output. (Choose FILE -> CLOSE or press CTRL+F4.)
· Pressing CTRL+TAB to switch back to the previous window.



Searching in askSam (Overview)

askSam's true strength is finding specific information when you need it and presenting it in a manner of 
your choice.    The list of possible searches is almost endless.    The Actions menu contains the various 
search options, as well as the Multiple Search Dialog Box, which allows you to form a request by linking 
the other Search options.    If you prefer, askSam's Command Line allows you to directly access askSam's
Search capabilities by entering Search commands.

Global Versus Local Searches
Because askSam allows you to create files which conceivably could span 4 GB (gigabytes) and individual
documents as long as 16,000 lines, finding all the information you want in the minimum amount of time 
calls for defining the scope of a search which fits your needs.    Basically, there are two methods of looking
for information

Global    Searches
Most of askSam's searches are conducted at the Global Level --    this Search is conducted through 
all the the documents in the current askSam file.    The Command Line and the various Searches in 
the Actions menu are all Global.

Local    Searches
When a file contains long documents, it is possible to confine a Search to a single document.    This 
local search is called a Find and searches only for a single text string in the current document.    You 
can access the Find command from the Edit menu.

askSam Local Search Options
·     Find   
·     Repeat Last Find   

askSam Global Search Options
·      Boolean Search   
·      Search in Field   
·      Numeric Search   
·      Proximity Search      
·      Date Search   
·      Multiple Search Request   
·      Search Multiple Files   
·      Hyper on Selected   
·      Hyper on File   

Wildcard Searches
askSam allows the wildcard symbols * and ? to be used in Searches.

· The * character is used to represent multiple characters (up to eighty).
· The ? character takes the place of a single character.

Examples:
Entering German* will find: German, Germans, Germany, Germanic, German-made



Entering German? will find: Germans and Germany - but not German, Germanic, or German-made.

Showing Matches
When you search for a word or phrase, askSam highlights it. The Show All Matches setting determines 
whether only the first match is highlighted or whether all occurrences are highlighted. A secondary 
function of this setting pertains to field output. If the same field occurs multiple times in a Document, it will 
be output multiple times when this option is checked.

To modify this setting:
1. Choose OPTIONS -> FILE PREFERENCES.

The File Preferences Dialog Box will appear.

2. Select the Show All Matches Option.

3. Choose OK.

Case Sensitive Searches
Normally, when askSam searches for a word, the case of the letters comprising the word is irrelevant. For
example, searching for WHO finds "Who", "who" and "WHO".    You can make searches Case Sensitive:

1. Choose OPTIONS -> FILE PREFERENCES.
The File Preferences Dialog Box will appear.

2. Select the Case Sensitive Searches Option.

3. Choose OK.

Searches can also be made Case Sensitive by clicking on the Case Sensitive Button. The Button 
toggles the setting ON and OFF.

Fuzzy Searches
Fuzzy Searching helps you locate information when you're not sure of the spelling, for example, if you 
were looking for documents containing the name "Kathy". You could use askSam's fuzzy search and find 
documents with "Kathy", "Kathi", or "Cathy". See Fuzzy Searching.

Index Searches (only available in the askSam Professional version)
Full-Text Indexing greatly speeds up searching in askSam files, especially in large files. With full-text 
indexing, you can search through a several hundred MB askSam file in a matter of seconds. Full-Text 
indexing is only available in the Professional version of askSam. See Indexing.



The askSam Word Processor (Overview)

askSam for Windows offers you many powerful Word Processing capabilities which allow you to take full 
advantage of the Windows' environment.    The basics of askSam's Word Processing functions similar to 
other Windows Word Processors and Text Editors.

·      Moving Around Within a Document   
·      Deleting Text   
·      Selecting Text   
·      Using the Clipboard - Cut, Copy, & Paste   
·      Drag and Drop Editing   
·      Using Fonts and Font Styles   
·      Text Alignment   
·      Setting Tabs   
·      Setting Margins and Indents   
·      Breaking Documents into Pages   
·      Using Headers and Footers   



Moving in a Document (Step-by-step Instruction)

You can use the mouse or the keyboard to move around in the current document.

To Move in the Document using the Mouse
1. You can use either the Vertical or Horizontal Scroll Bar to scroll through the current document. These

Scroll Bars function the same as those found in other Windows applications.
2. To position the cursor, move to the desired position and click the left mouse button.

To Move in the Document using the Keyboard
askSam includes a number of Key combinations for moving in a document:

Left Arrow Previous Character
Right Arrow Next Character
Up Arrow Previous Line
Down Arrow Next Line
Home Beginning of the Current Line
End End of the Current Line
Page Up Previous Screen
Page Down Next Screen
Ctrl+Left Arrow Previous Word
Ctrl+Right Arrow Next Word
Ctrl+Home Beginning of Document
Ctrl+End End of Document
Ctrl+PgUp Scrolls Screen Left
Ctrl+PgDn Scrolls Screen Right
Ctrl+Up Arrow Scrolls Screen Up
Ctrl+Down Arrow Scrolls Screen Down

_______________
See also

Shortcut Keys



Deleting Text (Step-by-step Instruction)

If you make a mistake while typing, you can easily Delete the mistake and replace it with the correct text.

Del Deletes the character to the right of the cursor or deletes the Selected Text.

Backspace Deletes the character to the left of the cursor or the Selected text.

Any Key Delete the Selected text.
_______________
See also

Selecting Text
Deleting an Entire Document



Selecting Text    (Step-by-step Instruction)

Use either the mouse or keyboard to select text. A selection can be copied, formatted, printed, exported, 
or deleted.

To Select Text Using The Mouse
1. Position the mouse pointer at one end of the text you wish to Select.
2. Press and hold down the Left Mouse Button.
3. Move the mouse pointer over the text.
4. Release the Left Mouse Button. The text you Selected is highlighted.

NOTE:    You can also Select an entire line by Clicking once on the Selection Area (the white margin 
to the left of the left margin).

To Select Text Using The Keyboard
Use the Cursor Keys in combination with the Shift Key to Select text (see Moving in a Document).
1. Place the cursor at one end of the text you wish to Select.
2. Press and hold down the Shift Key.
3. Use the Cursor Keys to move over the text you wish to Select.
4. Release the Shift Key. The text you Selected is highlighted.

To Cancel A Selection
· Click the Left Mouse Button
· or press any Arrow Key (Cursor Up, Cursor Down, Cursor Left, Cursor Right,    PgUp, PgDn)



Using the Clipboard (Step-by-step Instruction)

The Windows Clipboard provides a temporary storage area for information which you want to transfer to 
another location.    You can Cut or Copy information from your document to the Clipboard, and then 
transfer it to:

· Another place in the same document.
· Another askSam document.
· Another askSam file.
· Another Windows application.

To Cut or Copy Information to the Clipboard
1. Select the text or graphic.

2. Choose EDIT -> CUT    (Ctrl+X or  ) or

Choose EDIT -> COPY (Ctrl+C or  )

Cut The Selected Text is Deleted from the document when it is transferred to the Clipboard.

Copy The Selected text is left in the document and a copy is transferred to the Clipboard.

To Paste Information from the Clipboard
1. Position the cursor where you wish to insert the information from the Clipboard.

2. Choose EDIT -> PASTE (Ctrl+V or  ). 
The information stored in the Clipboard is pasted in the document at the cursor position.

NOTE: When you paste text into a document, the text and formats (fonts, sizes, colors, etc.) are 
pasted.    If you want to paste text without any formats, use the Paste Special command and choose 
the unformatted Text option.

_______________
See also

Cut command (Edit menu)
Copy command (Edit menu)
Paste command (Edit menu)
Paste Special command (Edit menu)



Drag and Drop Editing (Step-by-step Instruction)

Drag and Drop Editing offer you a fast and easy way to edit information using the mouse.

To Move Text Using Drag and Drop
1. Select the text you want to Drag and Drop. (See Selecting Text)
2. Place the mouse pointer in the Selected Text.
3. Press and hold the Left Mouse Button.
4. Move the mouse pointer and the blinking Text Bar to the location where you want to insert the text. 

The blinking text bar shows you the exact location of where your text will be inserted.
5. Release the Left Mouse Button. The text is moved from where you marked it to where you placed it. 

After inserting the text, askSam selects the newly inserted block

To Copy Text Using Drag and Drop
1. Select the text you wish to Drag and Drop. (See Selecting Text)
2. Using the mouse, place your mouse pointer in the Selected Text.
3. Press and hold the Ctrl Key.
4. Press and hold the Left Mouse Button.
5. Using the mouse, move the mouse pointer and the blinking Copy Bar to the location where you wish 

to insert a copy of the text. The blinking text bar shows you the exact location of where the text will 
be inserted.

6. Release the Left Mouse Button and your Ctrl Key. Your text will be copied from where you marked it 
to where you placed it. The Selected text will remain in its original location.



Using Fonts and Font Styles (Step-by-step Instruction)

When you begin entering text in a document, the text appears in the default font.    

To Choose a Different Font, Font Size, or Color
1. Choose FORMAT -> FONT.

The Font Dialog Box appears. 
2. Choose the Font, Style, Size, Color, and Effects you want to use.
3. Choose OK. 

The settings you selected are activated. The next text you enter will appear in the new Font.

To Change the Default Font for New Documents Added to a File
1. Choose OPTIONS -> FILE     PREFERENCES  .
2. Select the File Font Button.
3. Choose the Font, Style, Size, Color, and Effects you want to set as the Default Font.
4. Choose OK.

The settings you selected are defined as defaults for the current file.

To Change the Font of Existing Text
1. Select the text you want to modify.    See Selecting Text. 
2. Choose FORMAT -> FONT.
3. Choose the Font, Font Style, Size, Color, and Effects you want to use.
4. Choose OK. 

The Selected text is changed to the new Font settings.

Changing the Font from the Format Bar
1. Click on the drop-down Font menu on the Format Bar. 

The drop-down Font Menu appears displaying the fonts installed in your Windows system.
2. Type or select the Font you want to use. 

The drop-down Font Menu will close. The next text you enter at the cursor position, or the selected 
text is displayed in the new Font.

Changing the Font Size from the Format Bar
1. Click on the drop-down Font Size menu on the Format Bar. 

A list of available Font Sizes is displayed.
2. Choose the Font Size you want. 

The drop-down Font Size Menu will close. The next text you enter at the cursor position, or the 
Selected text is displayed in the new Font Size.



Changing the Font Style from the Format Bar
1. Click on either the Font Style Icon you want to use.

Bold  (Ctrl+B)

Italic  (Ctrl+I)

Underline  (Ctrl+u)
The next text you enter at the cursor position, or the Selected text is displayed in the new Font Style.



Text Alignment (Step-by-step Instruction)

Text can be aligned in the following ways:
· On the Left Margin
· On the Right Margin
· Centered between the two margins

To Change the Alignment Using the Menu Bar
1. Select the text you wish to modify or place the cursor in the line you wish to modify.    See Selecting 

Text.
2. Choose FORMAT -> ALIGNMENT 

A menu with the Alignment choices will be displayed.
3. Choose the Alignment command you want to use (Left, Centered, Right). 

The selected text or the line containing the cursor is realigned.

To Change the Alignment Using the Format Bar
1. Select the text you want to modify or place the cursor in the line you wish to modify.    See Selecting 

Text.
2. Click on the Alignment Icon you want to use

Left     

Center     

Right     
The Selected text or the line containing the cursor is realigned.



Setting Tabs (Step-by-step Instruction)

Tab settings control where the cursor is placed each time the Tab key is pressed.    As a default setting, 
askSam places tabs every half inch.    You can use either the Ruler or the Tab menu to set your own tabs. 
These settings will override askSam's default settings.

To Set Tabs From the Tab Menu
1. Choose FORMAT -> TABS. 

The Tabs Dialog Box appears.
2. Enter a measurement (in inches).
3. Choose the Set Button. 

This defines where your Tab is set. Repeat steps 1 through 3 for all Tabs you want to set.
4. Choose the OK Button to accept the Tab settings. 

The new Tab settings are in effect for the selected text or the line containing the cursor.

To Delete a Tab Using the Tab Menu
1. Choose FORMAT -> TABS.
2. Select the measurement for the Tab you want to delete in the Tab Stop Position List.
3. Choose the Clear Button. 

Repeat this for any other Tabs you want to delete. If you want to delete all Tabs, choose the Clear All
Button.

To Set a Tab Using the Ruler Line
1. With the mouse, Click on the Ruler where you want to set a Tab. An arrow will appear in the Ruler 

and a Tab is set where you Clicked.
2. Click again to set any other Tabs.

Click and Drag any Tab whose position you wish to modify. The new Tab Settings are in effect for the
Selected text or the line containing the cursor.

To Delete Tabs Using the Ruler Line
1. Click and Drag the Tab you wish to delete from the Ruler Line into the Work Space. The Tab is 

deleted.
_______________
See also

Tab command (Format menu)



Setting Margins and Indents (Step-by-step Instruction)
 
Margins and Indents affect the way your document prints.    Margins are set for the entire document while 
Indents may be set on a line-by-line basis.

To Set Margins for a Document
1. Choose FILE -> PAGE     SETUP  .

The Page Setup Dialog Box is displayed.
2. Type the size you want for the Top, Bottom, Left, and Right Margins.
3. Choose Document Settings.
4. Choose OK to accept the settings. 

The new Margin settings are now active in the current document. The appearance of the document 
on the screen is not altered to reflect the new settings. (Margin settings are reflected only when 
printing.)

5. Choose FILE -> SAVE (or press Ctrl+S) to save the new Margin settings.

To Set Margins for a File
The settings entered when the File Settings Option is selected in the Page Setup Dialog Box will override 
any Document specific settings already defined.    The File Settings remain active until you select the 
Document Setting Option in the Page Setup Dialog Box.
1. Choose FILE -> PAGE SETUP.

The Page Setup Dialog Box is displayed.
2. Type the size you want for the Top, Bottom, Left, and Right Margins.
3. Choose the File Settings Option.
4. Choose OK to accept the settings. 

The new Margin settings are now active in the current file. The appearance of the document on the 
screen is not altered to reflect the new settings. (Margin settings are reflected only when printing.)

5. Choose FILE -> SAVE (or press Ctrl+S) to save the new Margin settings.

To Indent Text in Documents
Indents can be set on either the left or right side of the page. You can indent the first line of a paragraph, 
or you can define a hanging indent which indents all lines but the first line. Indents may be set on a line-
by-line basis.

1. Move the cursor to the line you wish to indent, or select the text you wish to indent.
2. Choose FORMAT -> INDENTS.

The Indent Dialog will appear.
3. Enter your Indent settings.

You can enter a value for your Left and Right indentation. The Type Option lets you define a First 
Line or Hanging Indent.

4. Choose OK.
The Indents you defined are set in the defined text or the current line.



NOTE: Margins and Indents are similar, but they serve different purposes. Margins are set for an entire 
Document, whereas Indents can be set on a line-by-line basis. Indents are displayed on screen. Margins 
are not displayed, they only affect printing. Generally, margins are used when you print on different size 
paper, stationary, or labels. Indents are used to format documents.



Breaking Documents into Pages (Step-by-step Instruction)

askSam can automatically set page breaks, or you can manually define page breaks within your 
document.

To Automatically Set Page Breaks
1. Choose FORMAT -> REPAGINATE.

askSam goes through your Document and divides it into pages. Page Breaks are represented in 
your Document by a dotted line across the screen. 
If you wish to change the placement of an automatic Page Break, insert a Manual Page Break before
the automatic Page Break and repaginate the Document.

NOTES: 
1. If a Document has been edited prior to printing, it should be Repaginated before you print. This will 

insure that the Page Breaks on the screen match those in the actual printout.
2. Even if you don't choose the Repaginate option, askSam will automatically break your Document 

into pages when printing. It is, therefore, not necessary to repaginate before printing.

To Insert a Manual Page Break

1. Position the cursor where you want the Page Break to occur.
2. Choose FORMAT -> SET PAGE BREAK.

A dotted and dashed line will appear in the Document to show where the Page Break has been 
inserted.

To Remove a Manual Page Break
1. Position the cursor in the line above the Page Break
2. Choose FORMAT -> REMOVE PAGE BREAK.

The line representing the Page Break will be removed.

NOTES:
1. The Remove Page Break command cannot be used to remove Automatic Page Breaks. Automatic 

Page Breaks can only be changed by Repagination after inserting manual Page Breaks.
2. If you find Automatic Page Breaks annoying after Pagination, they can be removed.    Simply close 

and reopen the file.    Since Automatic Page Breaks are not saved with the file, this will clear the lines
from your screen. Manually inserted Page Breaks are saved with the file.

3. If the Word Wrap setting is on, REPAGINATING also re-wraps your text.



Using Headers and Footers (Step-by-step Instruction)

Headers and Footers are defined either for a Document or for the entire file. They will be printed at the 
beginning or end of every page in your Document. They may contain:

· Text (Left, Centered or Right Justified)
· Page Numbers and Total Number of Pages
· Date, Time, and Weekday
· File Name (with or without the Path)

Defining a Header or Footer
1. Choose FILE -> PAGE SETUP.

The Page Setup Dialog Box will appear.

2. Choose either the Header or Footer Button.
The Header or Footer Dialog Box will appear.

3. Enter your Header or Footer.    Press CTRL+ENTER to move to the next line.

The Buttons above the text zone let you insert the following Commands in your header or footer (you
can use the Button or type the command directly into the header or footer):

 Page Number Inserts the page number. Command ^N.

 Total Pages Inserts the total number of pages. Command ^P.

 Date Inserts the current system date. Command ^D.

 Time Inserts the current time. Command ^T.

 File Name Inserts the name of the current askSam file. Command ^f.

 Path / File Name Inserts the name and path of the current askSam file. Command ^F.

 Left Align Left aligns the header or footer. Command ^L.

 Center Centers the header or footer. Command ^C.

 Right Align Right aligns the header or footer. Command ^R.

The Font Button lets you set a font and font style for your Header or Footer.

4. Choose OK.
You return to the Page Setup Dialog Box. Repeat this process to define a Footer or choose OK to 
return to your Document.

5. Choose FILE -> SAVE (or press CTRL+S) to save the Header or Footer.

NOTES:
1. Headers and Footers are only displayed when a Document is printed.
2. When the Document Settings option is selected, the Header or Footer is defined for the active 

Document. When the File Settings option is selected, the Header or Footer is valid for every 
Document in the file. The File Setting option temporarily overrides the Headers and Footers you've 



defined in your individual Documents.
3. Headers and Footers are output at the beginning and end of the text printed on your page. To leave 

space between a Header and the first text on your page, insert a blank line (or lines) at the end of 
your Header. To leave space between a Footer and the last text on your page, precede the text in 
your Footer with a blank line (or lines). To adjust the distance from the edge of the page to your 
Header or Footer change the Top and Bottom Margins.



Close command (File menu)

Use this command to close an askSam file.

Shortcut
Keys: Ctrl+F4

Note:    If changes were made to the file since you the last saved, the Save Dialog Box is displayed.    See 
the Save command (File menu).



Exit command (File menu)

Use this command to exit askSam.

Shortcut
Keys: Ctrl+F4

Note:    If any unsaved files are open when you choose the Exit command, the Save Dialog Box will 
appear.    See the Save command (File menu).



Current Document (Export Sub-menu)

Use this command to export your current askSam document into another format and file. You can export 
from askSam into a text file, word processing file, HTML file, askSam file, and more.
______________________

See also:
Export for information on the options in the Export dialog box.
Step by Step Instructions for detailed information on how to export.



Entire File command (Export Sub-menu)

Use this command to export your entire askSam file into another format and file. You can export from 
askSam into a text file, word processing file, HTML file, Comma Delimited file, askSam file, and more.
______________________

See also:
Export for information on the options in the Export dialog box.
Step by Step Instructions for detailed information on how to export.



Tagged Document command (Export Sub-menu)

Use this command to export the Tagged document into another format and file. You can export from 
askSam into a text file, word processing format, HTML format, askSam file, and more.

This option is only available if you have a Tagged document in your file.
______________________

See also:
Export for information on the options in the Export dialog box.
Step by Step Instructions for detailed information on how to export.



Selected Text command (Export Sub-menu)

Use this command to export selected (highlighted) text into another format and file. You can export from 
askSam into a text file, word processing file, HTML file, and more.
______________________

See also:
Export for information on the options in the Export dialog box.
Step by Step Instructions for detailed information on how to export.



Report command (Export Sub-menu)

Use this command to export the output of a report. You can export a report into a text file, word 
processing file, HTML file, another askSam file, and more.

If you choose this option, a list of your reports will appear. Choose the report you wish to export, and the 
Export dialog box will appear.
______________________

See also:
Export for information on the options in the Export dialog box.
Step by Step Instructions for detailed information on how to export.



Date Stamp command (Edit menu)

Use this command to insert the system date at the cursor position.

Shortcuts
Toolbar:  

Keys: Ctrl+D

________________
See also

Time Stamp command (Edit menu)
Weekday Stamp command (Edit menu)



Time Stamp command (Edit menu)

Use this command to insert the time at the cursor position.

Shortcuts
Toolbar:  

Keys: Ctrl+T

_______________
See also

Date Stamp command (Edit menu)
Weekday Stamp command (Edit menu)



Weekday Stamp command (Edit menu)

Use this command to insert the weekday at the cursor position.

_______________
See also

Date Stamp command (Edit menu)
Time Stamp command (Edit menu)



Normal Style Command (Style Sub-menu)

Use this command to remove set styles for the selected text. Change bold, underline, italic, and other 
texts back to normal.

_______________
See also

Style command (Format menu)



Bold Style command (Style Sub-menu)

Use this command to turn the selected text or the text entered at the cursor position bold.

Example: Bold Text

Shortcut
Toolbar:  

Key: Ctrl+B

______________
See also

Style command (Format menu)



Italic Style command (Style Sub-menu)

Use this command to turn the selected text or the text entered at the cursor position Italic.

Example: Italic Text

Shortcut
Toolbar:  

Key: Ctrl+I

________________
See also

Style command (Format menu)



Underline Style command (Style Sub-menu)

Use this command to underline the selected text or the text entered at the cursor position.

Example: Underlined Text

Shortcut
Toolbar:  

Key: Ctrl+U

________________
See also

Style command (Format menu)



Strikeout Style command (Format menu)

Use this command to strikeout the selected text or the text entered at the cursor position.

Example: Strikeout

_______________
See also

Style command (Format menu)



Word Wrap command (Options menu)

Use this command to turn the askSam word wrap function ON or OFF.    The default setting for word wrap 
is ON.

When Word Wrap is on, askSam wraps texts:
· when you type
· when you import
· when you repaginate.

Note:    When the askSam Word Wrap function in ON, Wrap appears in the Status Bar.



Date Searching

The Date Search finds information according to a date contained in a field. The date search contains 
three categories:

· Single Range - "Find documents dated earlier than..."
· Dual Range - "Find documents from 1970 to 1980"
· Comparison - "Find documents dated later than 30 days from today"

_______________
See also

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Select Document(s) command (Export Sub-menu)

Use this command to export documents you select using askSam's Multiple Search Request. You can 
export these documents into a text file, word processing file, HTML file, Comma Delimited file,    askSam 
file, and more.
______________________

See also:
Export for information on the options in the Export dialog box.
Step by Step Instructions for detailed information on how to export.



Single Range Date Search (Actions menu)

Use this command to search for documents where a field is less than, greater than, or equal to a specific 
date.

For example, you would use this search type to:
· Locate Documents where the CALLBACK[ field is less than or equal to today's date.
· Locate Documents where the ACTUAL_FINISH[ field is less than the PLANNED_FINISH[ field.

Dialog Box Options

Date Field
Type or select the name of the Date field.

Logical Operator
Type or select a logical operator (<, <=, = >, >=, <>).

Second Date Field
There are three options for defining the second date variable.

1. Type or select the name of a second date field that you want to use to conduct a search based on a 
comparison of two date fields.

2. Click the Date Box and enter a date to use.
3. Click the Current Date Box to conduct a search based on comparison of the current date and the 

date in the field.

_____________
See also

Dual Range Date Search 
Comparison Date Search 

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Dual Range Date Search (Actions menu)

Searching for a range of dates lets you search for Documents with dates within a specific range:
For example, you would use this search to:

· Locate Documents with dates from the third quarter of 1995.
· Find people born from 1960 to 1970.

Dialog Box Options

Date Field
Type or select the name of the date field.

Logical Operator
Type or select a logical operator    (<, >, =, <=, >=, <>).

First Date
Click the Box to enter a date for the Date Search comparison.

Current Date
Click the Box if you want to use the current date in the Date Search comparison.

And
Click the Box to enter a second date in the Date Search comparison.

Logical Operator
Type or select a logical operator (<, >, =, <=, >=, <>).

Second Date
Click the Box to enter a second date in the Date Search comparison.

Current Date
Click the Box to use the current date in the Date Search comparison.

_______________
See also

Single Range Date Search 
Comparison Date Search 

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 





Prompt

When the Multiple Search Dialog Box appears in the report writer it contains an additional button. 
This button allows you to stop a report and prompt the user for input. It allows the user to modify the 
selection each time a report is run.



Comparison Date Search (Actions menu)

The Date Comparison Dialog Box allows you to search using an amount of time (days, months, or years) 
as your criteria. It allows you to compare a Date field to a date or another Date field and search on the 
time difference.

This could be used to:
· find all employees over the age of 50.
· show all accounts outstanding for more than 45 days.
· Show all artists who died before they were 50.

Dialog Box Options

Date Field
Type or select the name of the date field containing the first date.

Second Date Field
Type or select the name of the date field containing the second date or enter a specific date.

Current Date
Click the Box to use the current date.

Logical Operator
Type or select a logical operator (<, >, =, <=, >=, <>).

Qty of
Type a number to define the amount of time to use in the Date Search comparison.

Date Units
Select the date unit you want (Days, Months, or Years).

_______________
See also

Single Range Date Search 
Dual Range Date Search 

Boolean Search 
Search in Field 
Numeric Search 
Proximity Search 
Date Search 
Multiple Search Request 
Search Multiple Files 
Hyper on Selected 
Hyper on File 

Find 
Repeat Last Find 



Normal Style command (Format menu)

Use this command to remove set styles for the selected text. Change bold, underline, italic, and other 
texts back to normal.

_______________
See also

Style command (Format menu)



Center Tab command (Format menu)

Use this command to define a center tab for the selected text or the line containing the cursor. After you 
set a center tab, text entered at that tab position is centered on the tab.

Shortcuts
Toolbar:  

To set a center tab
Place the cursor on the line where you want a center tab. Click on the center tab button in the format bar. 
Click on the position in the ruler where you want a center tab. The center tab is set for the line where the 
cursor is currently located.

To remove a center tab setting
Select the center tab measurement on the ruler with a mouse and drag it off the ruler.

____________
See also

Tabs (Format Menu) 
Right Tab 
Left Tab 
Decimal Tab 



Right Tab command (Format menu)

Use this command to define a center tab for the selected text or the line containing the cursor. After you 
set a right tab, text entered at that tab position is right aligned on the tab.

Shortcuts
Toolbar:  

To set a right tab
Place the cursor on the line where you want a right tab. Click on the right tab button in the format bar. 
Click on the position in the ruler where you want a right tab. The right tab is set for the line where the 
cursor is currently located.

To remove a right tab setting
Select the right tab measurement on the ruler with a mouse and drag it off the ruler.

____________
See also

Tabs (Format Menu) 
Left Tab 
Center Tab 
Decimal Tab 



Decimal Tab command (Format menu)

Use this command to define a decimal tab for the selected text or the line containing the cursor. After you 
set a decimal tab, text entered at that tab position is aligned on the decimal point at the tab.

Shortcuts
Toolbar:  

To set a decimal tab
Place the cursor on the line where you want a decimal tab. Click on the decimal tab button in the format 
bar. Click on the position in the ruler where you want a decimal tab. The decimal tab is set for the line 
where the cursor is currently located.

To remove a decimal tab setting
Select the decimal tab measurement on the ruler with a mouse and drag it off the ruler.

____________
See also

Tabs (Format Menu) 
Right Tab 
Center Tab 
Left Tab 



1.5 Line Spacing command (Format menu)

Use this command to define the line spacing for the selected text or the text entered at the cursor position
(single, 1.5, and double).    The default setting in askSam is single line spacing.

Shortcut
Toolbar:  

Sub-menu Options

Single
Defines the line spacing for the text as single space.

1.5 Lines
Defines the line spacing for the text as 1.5 lines.

Double
Defines the line spacing for the text as double.

_______________
See also

Single Line Spacing command (Format menu)
Double Line Spacing command (Format menu)



Double Line Spacing command (Format menu)

Use this command to define the line spacing for the selected text or the text entered at the cursor position
(single, 1.5, and double).    The default setting in askSam is single spacing.

Shortcut
Toolbar:  

Sub-menu Options
        
Single
Defines the line spacing for the text as single space.

1.5 Lines
Defines the line spacing for the text as 1.5 lines.

Double
Defines the line spacing for the text as double.

_______________
See also

Single Line Spacing command (Format menu)
1.5 Line Spacing command (Format menu)



Menu Bar

The features of askSam for Windows can be selected using the traditional Windows Menu Bar at the top 
of the screen.    You can choose a menu item either with your mouse or the keyboard (by using ALT Key 
combinations).

Selecting Menu Items with a Mouse
You can choose Menu items with a mouse or other pointing device.    Simply move the Mouse Cursor (it 
will become an arrow) to the Menu item of your choice and Click.    Options on the Pull-Down Menus can 
be selected in a similar manner.

Selecting Menu Items with the Keyboard
1. To access a menu with the Keyboard, press the ALT key plus the underline letter in the Menu.

A Pull-Down menu appears. 
2. You can now choose the desired menu option by pressing the underlined letter or number.

Alternate Keyboard Selection Method (Using the Arrow Keys)
3 Press the ALT Key to move the cursor to the Menu Bar.
3 Use the ARROW Keys to move to the desired option.
3 Press ENTER.



Status Bar

The bottom line of the askSam screen is the Status Bar.    From the Status Bar, askSam give you 
messages and other useful information.

1. The left most section of the Status Bar is where askSam displays messages.    Descriptions of Menu 
Items and Buttons, as well as Prompts are shown here.

2. The next section of the Status Bar is the Document Counter.    It tells you how many documents are 
in the current file, and gives you the number of the current document.    For example, "1 of 22" 
means that you are currently at document number 1, and there are 22 documents in the file. If the 
Document Counter is turned off, choose VIEW ->     UPDATE DOCUMENT     COUNTER   to turn it back 
on.

3. The Column Number is the next section on the Status Bar.    This can be a number from 1 to 255, 
and gives you the horizontal cursor position in the Work Space.

4. The Line Number follows the Column Number.    It indicates the Line Number where the cursor 
appears in the Work Space.

5. The next five sections indicate the status of several modes: 
· Insert or Overwrite status.    An OVR is displayed when askSam is in Overwrite Mode.
· CAPS is displayed when Caps Lock mode is On.
· When Num Lock is On, NUM is displayed.
· The word DATA in the Status Bar indicates that Data Entry mode is On.
· The word WRAP indicates that the Word Wrap setting is On.



Report Tools (Tools Menu)

Use these tools to design and edit the layout in the Report Layout Editor.

Access these commands in the Report Layout Editor by choosing TOOLS -> REPORTS TOOLS or by 
clicking on the desired button in the Floating Tool Bar.

Place Field Selects a field and positions it in the Report.

Show Outputs Sentences, Lines, or Paragraphs containing specific words or phrases

Group Footer Adds text to totals and subtotals from the Total and Count commands.

Report Settings Defines settings specific to the current Report.

Count Places the number of Documents selected or grouped into your Report.

Place Text Places text into your Report.

Spacing Defines the spacing method when placing fields in a Report.

Header Defines a header for the Report.

Footer Defines a footer for the Report.

Reset Row Used to set a Report in multiple columns.

Close Closes the Report Layout Editor and lets you save or cancel your changes.

Floating Tool Bar Turns the Floating Tool Bar on and off.

Field List Turns the Field List on and off.



Show command in Reports

The Show command enables you to output text in a report even if the text you wish to output is not 
contained in a Field. With the Show command it is possible to output Sentences, Lines, or Paragraphs 
which contain specific words or phrases. For example, you could search through the entire testimony of 
the Iran-Contra hearings and output every line containing the phrase "Oliver North". 

Using the Show command in Reports

1. In the Report Layout Editor choose TOOLS -> REPORT TOOLS -> SHOW
(or click on the Show Button in the Tools Menu).

The Show dialog box will appear.

2. Enter the Word or Phrase you wish to locate
(or you can enter a prompt - see Note 1 for details). 

3. Enter a number in the quantity field.
This determines how many Words, Sentences, Lines or Paragraphs are output.

4. Choose either Words, Sentences, Lines, or Paragraphs for the output structure.

5. Choose a direction (Before, After, On Either Side Of, or Containing). 
This selection defines how much text is output.

6. Choose OK
You will return to the Report Layout Editor.

7. Click the mouse pointer where you want to place the text output by the Show command.
The Show command is inserted in your Report Layout. Example:    

[illegal search]1LE

NOTES:
1. Instead of entering a Word or Phrase, the Show command prompts you to enter a Word or Phrase. 

There are two types of prompts you can use with the Show command.
 

The "Use Last Prompt from Selection Criteria" option takes the prompt from the Selection part of 
the report and uses it as the Word or Phrase in your Show command. This lets you Select 
Documents containing a specific word or phrase and just output the text around that word or phrase.

The "Prompt" option prompts the user to enter a Word or Phrase for the Show command. The Word 
or Phrase entered, however, does not affect the Documents selected for inclusion in your report.

2. The "Column Size" option in the Show dialog lets you define a column in which the retrieved text will
wrap. If you do not specify a column size, the text will be wrapped in the default margin in your 
report.

3. The "Output First Structure" option outputs the first Word, Sentence, Line, or Paragraph from your 
Documents.



Title Bar

The askSam Title Bar contains the name of the active application (in this case askSam) and may also 
contain the name of the active file when you have opened one or more askSam files.



Ruler

The Ruler displays (and allows you to modify) Margin and Tab settings for the current document.



Work Space

The Work Space is where you enter your information.    Bring the cursor into the Work Space with the 
mouse or ARROW Keys, and begin typing.



Left Align command (Format menu)

Use this command to align the selected text or current line on the left margin.

Shortcut

Toolbar:

Left  

Center  

Right  



Center Align command (Format)

Use this command to center the selected text or current line between the two margins.

Shortcut

Toolbar:

Left  

Center  

Right  



Right Align command (Format menu)

Use this command to align the selected text or current line on the right margin.

Shortcut

Toolbar:

Left  

Center  

Right  



Close Report command (Tools Menu)

Use this command to close the Report Layout Editor.    A Dialog Box will prompt you to save the Report 
layout you created.

Shortcut
Report Tools  

Keys: CTRL-S



Links command (Edit menu)

Use this command to define whether a Link should be updated manually or automatically.    You can also 
use this command to break a Link between an Object in the Server Application and an Object in askSam.

Dialog Box Options

Links
Lists the Links in the current document.

Automatic Automatically updates the Linked object to display any changes made in the Server 
Application.

Manual Requires you to manually request that the Linked Object be updated.



Object command (Edit menu)

Use this command to edit a Linked Object in askSam.

Note:    By selecting the Linked Object you wish to edit and choosing this command, the Server 
Application will open and the Object will be displayed.    Edit the Object using the features of the Server 
Application.



Case Sensitive command (Menu Bar)

Use this Icon to define an askSam search as Case Sensitive.    Use this Icon to toggle the setting ON and 
OFF.

Note:    Normally, when    askSam searches for a word, the case of the letters comprising the word is 
irrelevant.    For example, searching for WHO finds "Who", "who" and "WHO".    

_______________
See also

File Preferences (Options menu)



Minimize Button

Using a mouse, you can click the Minimize Button to reduce the current application window to an Icon.

_______________
See also

Maximize Button 



Maximize Button

Using a mouse, you can click on the Maximize Button to enlarge the current application window so that it 
fills the entire desktop.

_______________
See also

Minimize Button 



Scroll Bar

Using a mouse, you can click on the Scroll Bars to move the current document up and down (Vertical 
Scroll Bar) and left and right (Horizontal Scroll Bar). This lets you view parts of the document that do not 
fit into the window.



Control Menu Box

The Control Menu Box is in the upper left corner of each window.    By using the Control Menu commands,
you can resize, move, maximize, minimize, and close windows, and switch to other applications.    



Background Color (Format Menu)

askSam lets you modify the background color of your text. To change the color of a text:

1. Select the text you wish to modify.

2. Choose FORMAT -> BACKGROUND COLOR 
The Color Menu appears allowing you to choose a color for your the selected background.

3. Choose a color.
The color of the Selected Text background will be modified.

NOTE: The COLOR Commands can be accessed from the Mouse Menu. Click the Right Mouse Button in
the Work Space to display the Mouse Menu.
_______________
See Also

Foreground Color 



Foreground Color (Format Menu)

askSam lets you modify the color of your text. To change the color of a text:

1. Select the text you wish to modify.

2. Choose FORMAT -> FOREGROUND COLOR 
The Color Menu appears allowing you to choose a color for your text.

3. Choose a color.
The color of the Selected Text will be modified.

NOTE: The COLOR Commands can be accessed from the Mouse Menu. Click the Right Mouse Button in
the Work Space to display the Mouse Menu.

_______________
See Also

Background Color 



Command Line

askSam's Command Line is the direct route to your information. When using the Command Line it is 
never necessary to specify a field for searching. Simply type in a name, company, date or any other word 
that you're looking for and askSam will find it in the Active File.

Shortcuts:
Keys: Esc
Mouse: Place cursor in blank area and click mouse button once

Icon:  

Searching from the Command Line:

1. Press ESC to move to the Command Line.
With a mouse, place the mouse pointer in the Command Line and Click.

2. Type the word or phrase for the Search or select a previous search from the drop down list  , and 
press ENTER (or Click the Search Button).

askSam searches from the beginning of the Active File and displays the first Document containing 
the word or phrase you entered. The word or phrase is highlighted and the Retrieval Dialog Box will 
appear. 

Searching for Phrases
To Search for a phrase from the Command Line, the phrase must be enclosed in square brackets []. 
Entering multiple words that are not enclosed in square brackets results in a Search for Documents 
containing all the requested words but the words do not have to appear together as a phrase.

Example: Entering WORLD BANK in the command will find any Document containing the word 
"world" and the word "bank". This means that a Document containing the sentence, "In 
today's world, the bank is an important institution" would be selected. [WORLD BANK] 
Finds only Documents where the actual phrase "world bank" appears.

Entering Commands on the Command Line
It is possible to conduct more than simple Searches from askSam's Command Line. More complex 
Requests usually involve the use of askSam Commands. For certain Searches or Lists, you may find it is 
faster to enter the Requests from the Command Line.

Example: To search for all documents containing Ireland or England, you can enter the following 
request in the Command Line: IRELAND {OR} ENGLAND.    The "{or}" in the example above 
is an askSam Command.

NOTE: If you prefer to enter Requests directly in the Command Line (instead of using Dialog Boxes), 
the WIN_COM.ZIP file on our BBS contains a list of the commands and descriptions of their 
functions. You can also turn on the "Show Commands from Dialogs" option in the OPTIONS -
> GLOBAL PREFERENCES Menu. This option activates a Command Message Box which 
displays the Commands to enter in the Command Line to perform the function of any Search. 
The Message Box is displayed after executing any Command from the Actions Menu or when
running a report.





Tool / Format Bar

 
Tool Bar

 
New Open Save 
Print Pack Import 
Add Blank Add Entry Form Cut 
Copy Paste First 
Previous Next Last 
Tag Go Tagged Run Report 
Zoom In Zoom Out Dial 
Case Sensitive Help 

Format Bar

Font

 
Select a font for highlighted text. Use the arrow to display a list of available fonts, or type the name of the 
desired font.

Font Size

 
Select a font size for highlighted text. Use the arrow to display a list of available fonts, or type the name of
the desired font.

 
Bold Italic Underline 
Left Justify Center Justify Right Justify 
Left Tab Center Tab Right Tab 
Decimal Tab Single Spacing Half Spacing 
Double Spacing Date Stamp Time Stamp 
Spell Check 



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar 

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar 

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar 

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



Color Bar

Use this command to define the color for the selected text or the text entered at the cursor position.    

Select the color that you want to use.



HTML Format: Normal (Format menu)

Normal Text - Use this format for the standard text in your HTML documents. 

Select (highlight) the text you want to format. Then choose FORMAT -> HTML -> NORMAL

In askSam Normal Text is displayed in the 12 point Times Roman font.    Example:

ABC Corp. is one of fastest growing companies in the United States. 
Outstanding products and outstanding customer service have become 
trademarks of ABC....

______________
See Also

Creating HTML Documents



HTML Format: Main Title (Format menu)

Main Title - The Main Title defines the Title Text for the HTML Document you create. The Title is 
displayed in the Title Bar of your Browser (not in the Text of the HTML Document). 

Select (highlight) the text you want to format. Then choose FORMAT -> HTML -> MAIN TITLE

In askSam the Main Title is displayed in 10 Point System Italic, and it is centered. The Main Title must be 
in the first line of your askSam Document. Example:

                                                                  ABC Corporation Home Page

                    Welcome to ABC Corp's Home Page
ABC Corp. is one of fastest growing companies in the United States. 
Outstanding products and outstanding customer service have become 
trademarks of ABC....

______________
See Also

Creating HTML Documents



HTML Format: Heading 1 (Format menu)

Heading 1 - use for headings in your HTML Documents. 

Select (highlight) the text you want to format. Then choose FORMAT -> HTML -> HEADING 1

Heading 1 is displayed as:

Times Roman Bold 24
______________
See Also

Creating HTML Documents



HTML Format: Heading 2 (Format menu)

Heading 2 - use for headings in your HTML Documents. 

Select (highlight) the text you want to format. Then choose FORMAT -> HTML -> HEADING 2

Heading 2 is displayed as:

Times Roman Bold 20
______________
See Also

Creating HTML Documents



HTML Format: Heading 3 (Format menu)

Heading 3 - use for headings in your HTML Documents. 

Select (highlight) the text you want to format. Then choose FORMAT -> HTML -> HEADING 3

Heading 3 is displayed as:

Times Roman Bold 18
______________
See Also

Creating HTML Documents



HTML Format: Heading 4 (Format menu)

Heading 4 - use for headings in your HTML Documents. 

Select (highlight) the text you want to format. Then choose FORMAT -> HTML -> HEADING 4

Heading 4 is displayed as:

Times Roman Bold 14
______________
See Also

Creating HTML Documents



HTML Format: Heading 5 (Format menu)

Heading 5 - use for headings in your HTML Documents. 

Select (highlight) the text you want to format. Then choose FORMAT -> HTML -> HEADING 5

Heading 5 is displayed as:

Times Roman Bold 10
______________
See Also

Creating HTML Documents



HTML Format: Heading 6 (Format menu)

Heading 6 - use for headings in your HTML Documents. 

Select (highlight) the text you want to format. Then choose FORMAT -> HTML -> HEADING 6

Heading 6 is displayed as:

Times Roman Bold 8
______________
See Also

Creating HTML Documents



HTML Format: Un-numbered List    (Format menu)

Un-numbered List - use for bullet lists. 

Select (highlight) a text. Then choose FORMAT -> HTML -> UN-NUMBERED LIST

Un-numbered lists are displayed in 12 point Times Roman, indented, with bullets. To end an un-numbered
list, you must insert a blank line without any tab stops. Example:

    Breaking News
    August 25, 1995 4:00 p.m. ET

    · Hayes and Boca: Playing the waiting game
    · Compaq enlists Ingram for help with PC mail order
    · Microsoft celebrates Win 95 day as DOJ continues probe
    · Boca Research bails on Hayes merger; execs swap charges

______________
See Also

Creating HTML Documents



HTML Format: Numbered List    (Format menu)

Numbered List - use for numbered lists. 

Select (highlight) a text. Then choose FORMAT -> HTML -> NUMBERED LIST

Numbered lists are displayed in 12 point Times Roman, indented, and numbered. To end a numbered list,
you must insert a blank line without any tab stops. Example:

    Rugby World Cup - Match reports
    1.      25 May : South Africa v. Australia (27-18)
    2.      26 May :Scotland v. Cote D'Ivoire (89-0)
    3.      26 May : France v. Tonga (38-10)
    4.      26 May :Canada v. Romania (34-3)

______________
See Also

Creating HTML Documents



HTML Format: Definition List    (Format menu)

Definition List - use for lists of definitions. 

Select (highlight) a text. Then choose FORMAT -> HTML -> DEFINITION LIST

Definition lists are in 12 point Times Roman and have the format shown in the following example:

The askSam Product Line
ASKSAM FOR WINDOWS
                          an easy-to-use, free-form database for organizing information

ASKSAM FOR WINDOWS NETWORK VERSION
                        use askSam to share information in workgroups. Runs on any
                      Windows-compatible network. Supports record locking.

______________
See Also

Creating HTML Documents



HTML Format: Block Quote    (Format menu)

Blockquote -    use to indent text passages, for example quotations. 

Select (highlight) a text. Then choose FORMAT -> HTML -> BLOCK QUOTE

Example:

    In the words of Mark Twain:
 "When I was a boy of fourteen, my father was so ignorant I could 
hardly stand to have the old man around.    But when I got to twenty-one,
I was astonished at how much he had learned in seven years."

___________
See Also

Creating HTML Documents



HTML Format: Preformatted Text    (Format menu)

Preformatted Text -    use for texts that should not be reformatted, such as tables. 

Select (highlight) a text. Then choose FORMAT -> HTML -> PREFORMATTTED TEXT

Example:

 The following is a summary of your portfolio:

 Company  Invested      Current            P/L
 AT&T                                          5914.85        5200.00        -714.85

 Chrysler                                  8170.39        8825.00          654.61  

 China Industries                  4039.63        3876.00        -163.63 
 Diag. Retrieval Sys.          3512.60        6062.00        2549.40 

___________
See Also

Creating HTML Documents



HTML Format: Emphasis    (Format menu)

Emphasis - use to emphasize a word or passage. 

Select (highlight) a text. Then choose FORMAT -> HTML -> EMPHASIS

Text is displayed as bold and italic. 

___________
See Also

Creating HTML Documents



HTML Format: Horizontal Rule    (Format menu)

Horizontal Rule - places a line across the screen. Use to separate sections of a text in your Documents.

Select (highlight) a text. Then choose FORMAT -> HTML -> HORIZONTAL RULE

___________
See Also

Creating HTML Documents



Import Date Range Dialog Box

The Date Range dialog box allows you to import CompuServe messages before, after, or equal to a 
certain date. Before a message is imported, askSam checks the date field in the message to ensure it 
meets the date criteria you defined. This option lets you import only your newest messages. It is only 
available when importing CompuServe Information Manager files.

Dialog Box Options

Import messages that are 
Choose an operator. Either <, <=, =, >=, >, or <>. Then enter a date.

Enable date checking
Select this option to activate date checking when CompuServe messages are imported. 



Define Fields Dialog Box

Use the Define Fields dialog to import data from a CSV file, dBASE file, Tab Delimited file, or    Fixed 
Position file into askSam. The Define Fields dialog lets you assign field names to the data you import from
other applications.

The options available in the Define Fields dialog change when the Import Into Entry Form option is 
selected.

Define Fields - Import into Entry Form

When you import data into an Entry Form, the Define Fields dialog displays a list of fields from your 
askSam Entry Form. You also see a list of the data contained in the first record you will import. Assign 
your askSam fields to the corresponding data.

Using the Define Fields Dialog Box

1. Select the askSam field name that corresponds to the first entry in the data list and choose the Add 
button.

2. Repeat this procedure for all the fields you wish to import.
3. Choose OK to begin importing the data.

The data will be imported into your Entry Form.

Dialog Box Options

Import into Entry Form
If selected, data is imported into fields from the askSam Entry Form. Otherwise, you define field names 
and the data is imported into these fields. The options appearing in the dialog box change depending 
upon whether this option is selected or not selected.

Available Fields
Lists the fields form the askSam Entry Form.

Field
When you select an Available Field and choose Add, is moves to the Field List. It appears next to the data
that will be imported into it.

Data
Shows the data from the first record in the file you are importing.

Add
Moves the field you select from the Available Field list to the Field List. The field appears next to the data 
that will be imported into it.

Clear
Removes a field from the Field List. Use this is you insert an incorrect field in the field list.

Add All



Moves all the fields in the Available Field list to the Field List. The fields remain in the same order as they 
appear in the Available Field list.

Clear All
Removes all fields from the Field List.    

Define Fields - when not importing into an Entry Form

The Define Fields dialog box lets you define fields for data you import form dBASE, Comma Delimited, 
Tab Delimited, and Fixed Position files. The second column in this dialog contains data from the first 
record of your data.    In this dialog, you will define field names for the data that you import. 

Using the Define Fields Dialog Box

1. Choose the Set Button.
2. Type in a field name and choose the OK button.

This defines a field name for the first field you will import.
3. Use the cursor down key or the mouse to select the data for the next field. 

Repeat steps 1 - 3 until you've defined names for each of your fields.
4. After you define field names, choose the OK button to begin importing the Comma or Tab Delimited 

file.

Dialog Box Options

Import into Entry Form
If selected, data is imported into fields from the askSam Entry Form (see above). Otherwise, you define 
field names and the data is imported into these fields. The options appearing in the dialog box change 
depending upon whether this option is selected or not selected.

Fields Names
Lists the names of the fields you define.

Field Data
Shows the data from the first record in the file you are importing.

Set
Lets you enter a field name for data that you've selected.

Move Up
Moves the selected data and field name up one position. 

Move Down
Moves the selected data and field name down one position. 

Delete
Removes a field from the Field List. Use this is you insert an incorrect field in the field list.



Number of Hits

Note: The following functions are only available in the askSam Professional version.

When searching an indexed file, the number of hits for a search is displayed immediately. askSam 
Professional displays the number of hits in 3 separate ways:

· A Max Hits field is displayed in the appropriate search dialogs.
· When you execute a search, the Status Bar tells you how many Documents are selected, for 

example: "Hit 1 of 7".
· In the Word List, askSam displays the number of Documents containing each word in the index 

(See the description of the Word List).

Max Hits

If you search from the Actions menu (except for Numeric and Date Searches), the search dialog will 
contain a "Max Hits" field. The Max Hits field will display the maximum number of hits for the query you 
enter.

Why Max Hits?
askSam allows you to enter sophisticated searches that are not normally possible with text retrieval 
programs (for example date and numeric range searches). To make these searches possible,    askSam 
combines the advantages of indexing with other powerful search routines. The index gives you an 
estimate of the maximum number of hits. This lets you quickly decide if you've narrowed down your 
search to an acceptable number of Documents. As you go through and retrieve the documents the actual 
number of hits is updated in the Status Bar.

For an exact count for any type of search, use the Multiple Search Dialog. Enter your search, check 
"Count Selected Docs", and choose OK. askSam will execute the search and determine the exact number
of hits.

NOTES:
1. Boolean Searches - Max Hits will display the exact number of hits when you enter a word or words 

in the Command Line and when you use the Boolean Search dialog (except for the NOT operator 
and Case Sensitive Searches).    For example: 

A Boolean search for "Shakespeare" or "Schiller" gives you an exact number of hits.

A Boolean search for "Shakespeare" not "tragedy" displays Max Hits equal to the number of 
documents containing Shakespeare. The "not tragedy" part of the query is not evaluated until the 
search is executed.

2. Search In Field - In the Search In Field dialog, Max Hits displays the number of documents 
containing the word you enter. Not until you begin the search, does askSam check to see if the word 
is actually in the appropriate field.    For example:

Searching for FL in the STATE field will display Max Hits equal to the number of documents 
containing "FL". When the search is executed, askSam checks each document and retrieves only 
those where "FL" is actually in the field STATE.

3. Proximity Search - In a Proximity Search, Max Hits displays the number of documents containing 



the two words you enter. The proximity of the two words is not evaluated until the search is 
executed. For example:

A search for "illegal" and "substance" in the same sentence will display the number of documents 
containing the words "illegal" and "substance". When the search is executed, askSam checks each 
document and retrieves only those where "illegal" and "substance" appear in the same sentence.

4. Date and Numeric Searches - Date and Numeric searches do not use the index and do not affect 
the number displayed in Max Hits. Use the Count Selected Documents option in the Multiple Search 
dialog to count the number of Documents selected by a Date or Numeric search.

Hits in the Status Bar

When searching an indexed file, the number of hits for a search is displayed in the Status Bar. Rather 
than the normal display of "Doc 1 of 5000", you see "Hit 1 of 16" after you have started your search.

NOTE: The number of hits displayed in the Status Bar has the same limitations as the Max Hits described
previously. Unlike Max Hits, the display in the Status Bar is updated as you search the file.

___________
See Also

Count Selected Documents (Multiple Search Request command)
Count Word or Phrase



Fuzzy Searching

Fuzzy Searching helps you locate information when you're not sure of the spelling. For example, if you 
were looking for documents containing the name "Kathy", you could use askSam's fuzzy search and find 
documents with "Kathy", "Kathi", or "Cathy".

Using askSam's Fuzzy Search

To Use the Fuzzy Search from the Command Line:

1. Click on the Fuzzy Search Button (to the right of the Command Line). 

2. Press ESC or click the mouse in the Command Line.

2. Type the word or words you wish to find.

3. Press ENTER.

askSam will retrieve the first document containing the words or a fuzzy equivalent of the words you 
entered.

NOTE: Clicking the Fuzzy button affects only the next search you enter in the Command Line. To set
Fuzzy Searching as the default search type, choose OPTIONS -> FILE PREFERENCES and select 
the Fuzzy Search option.

To Use the Fuzzy Search from the Actions Menu:

1. Choose ACTIONS

2. Select the type of search you wish to execute.

3. Enter your search.

4. Select the Fuzzy option in the dialog.

5. Choose OK.

askSam will retrieve the first document containing the words or a fuzzy equivalent of the words you 
entered.

NOTE:    The Numeric and Date searches in the Actions menu do not offer Fuzzy Search 
capabilities.






